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1.1 Summary 
This is the release for the Crafty49s Book Folding Pattern Maker release V1.1.00 user guide. 

1.2 Supersedes 
None. 

1.3 Version History 
Version Date Details 
0.1.00 13 April 2015 Authors & Contributors at this version 

Ian Wadsworth. 
 
First issue.  

   

1.4 Copyright 
This document, test files, executables and related files are copyright of Ian Wadsworth (except where 
indicated), and must not be distributed to any un-authorised testers without the consent of Ian Wadsworth. 
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2. Release and System 
Requirements Information 
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2.1 Software Use 
• The software is supplied as is. It may contain defects, and may not be fit for purpose. 
• The author cannot be held responsible for any loss of data caused by using the application. 
• It has been checked for viruses, but it is up to the user to check that their system have the latest anti-

virus software installed and enabled. 

2.2 Copyright Acknowledgements 
All registered trademarks are recognised, and are not used to exclusively promote the application. 

2.3 End User Licence 
Please read the document ‘eula.rtf’. 
 

• The software is licensed, and is not owned. 
• No selling or renting of the executable file 
• Internationally copyright protected. 
• It may not be re-sold, rented, etc. 
• Please don't distribute the executable file, link it to this website 

2.4 3rd Party Licence 
The software uses a number of Open Source DLL libraries from Empira Software GmbH, Troisdorf (Germany) 
http://www.empira.de/. 

2.5 Release Notes 
New releases are at http://www.ideas-r-us-software.uk/Downloads.aspx, and an update can be checked from 
within the software (see 5.3.3 Check for Updates). 
 
A help forum is at http://www.ideas-r-us.co.uk/forum/ 

2.5.1 Known Issues 
None. 

2.5.2 Limitations of the Demo Release 
• Cannot save any of the pattern files 
• Cannot change any of the Pattern Details 
• Limited to a maximum of 75 book leaves 
• There is also an expiry date for Demo releases, so the licence ReleaseDemo1-0-

75Expires1Dec2016.licence will expire on the 1 December 2016 

2.5.3 Limitations of the Full and Trial Releases 
Trial releases have the features as Full releases, but will have a licence that will expire after a number of 
months after registration. And can only be used on one computer. 

http://www.empira.de/
http://www.ideas-r-us.co.uk/downloads.aspx
http://www.ideas-r-us.co.uk/forum/
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2.5.4 Changes Made in Version 1.1.00 
2.5.4.1 New Features 

• A Pattern Chart/Graph/Line/Stripes for marking the points, as opposed to measuring them. 
• A count of the number of cuts for a Cut and Fold pattern, the number of Folds for a Mark and Fold 

pattern, are displayed on the form and in the Pattern Details section on the Print/PDF output. 
• The pattern details Author, Website URL, Copyright and Comments are now saved and loaded 

automatically. 

2.5.4.2 Issues Fixed 
When a new image is loaded and the 'Remove Space Around Image' is checked, the Margins and Spaces group 
box is not disabled. Fixed. 

2.5.4.3 Improvements Made 
• The date format was changed from 01 January 2016 to 1 January 2016 on the Pattern Details section on 

the Print/PDF output. 
• Added the Pattern Type and Marking Method used to the PDF/Print document details. 

2.6 Reporting Issues (Bugs) 
Issues can be reported by going to the forum at http://www.ideas-r-us.co.uk/forum/. 

2.7 System Requirements 
• Requires Windows XP, Windows Vista, Windows 7, Windows 8.x or Windows 10. 
• A mouse or pointing device 
• A colour monitor of at least 1080 x 720 pixels. 
• At least 13MB of hard disk space 
• The application uses about 30MB of DRAM. 
• Adobe Reader for viewing the User Guide, from http://get.adobe.com/reader/otherversions/.  
• Requires the Microsoft .NET Framework 3.5 Service Pack 1 (Requires at least Service Pack 2 Win XP), 

if not already installed. The installer will detect if the framework is installed or not. 
o If you have Internet access it can be downloaded from http://www.microsoft.com/en-

gb/download/details.aspx?id=25150 (about 235MB) 
o If no Internet access, it may be on the operating systems install disk. 

 
The installed files are: - 
  

*.licence 
BookFolding.exe 
Crafty49sBookFoldingPatternMakerUserGuide.pdf 
eula.rtf 
LicenceAProduct.exe 
unins000.dat 
unins000.exe 

 

http://www.ideas-r-us.co.uk/forum/
http://get.adobe.com/reader/otherversions/
http://www.microsoft.com/en-gb/download/details.aspx?id=25150
http://www.microsoft.com/en-gb/download/details.aspx?id=25150
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3. The Application 
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3.1 Description 
The art of folding pages of a book to create a raised pattern is called Book Folding or Book Art. There may be 
other names for it. 
 
The application will simply take a raster image, and create a number of folding/marking points (pattern 
chart/graph/line/stripes). There is no guarantee that any image used will create a good folded book. 
 
The Cut and Fold is a different method, in that cuts are made into the page of the book and then folded. 
 
Below are some of the Folded Books made using both the Cut and Fold and the Mark and Fold methods, with 
the Crafty49’s Book Folding Pattern Maker. 

3.1.1 Cut and Fold 
Picture 1 Cute Bunny Cut and Folded (Sunken Pattern) Book by Helen Rich ©2016 
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Picture 2 Candle Cut and Folded (Raised Pattern) Book by Chris Ashworth ©2016 
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3.1.2 Mark and Fold 
Picture 3 Ballet Word Folded Book by Helen Rich ©2015 
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Picture 4 Westie Dog Folded Book - Decorated by Chris Ashworth ©2015 

 

3.2 Main Features 
This application will create a set of book art or book folding patterns from a raster (bitmap) image. These 
include a preview pattern image, and a list of fold marking points for the book. 
 

• Uses the Measure, Mark, and Fold Method (shortened to Mark and Fold), and the Measure, Mark, Cut 
and Fold Method (shortened to Cut and Fold) 

• Book size is from 5cm/50mm to 40cm/400mm 
• The number of folds can be up to 1,000 (2,000 pages) 
• Removes blank book leaves from the design pattern 
• Removes excess white from around the design pattern 
• Invert (make negative), and Mirror the design pattern 
• Add top and bottom margins to the design pattern 
• Add blank leaves before and after the design pattern 
• Adds ‘spacer folds’ between the design pattern for the Cut and Fold method 
• Choose between leaf or page numbering, with an adjustable start value 
• Supports most of the common raster image files 
• Image files can be dragged and dropped onto the main form 
• Copy and paste, from applications such as Paint and Word 
• Creates a PDF file with preview images and pattern marking points, pattern chart/graph/line/stripes 
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• Creates separate preview images and a CSV file of marking points for creating custom documents 
 
The supported raster image formats are: - 
 

• Bitmap (.bmp, .dib) 
• GIF (.gif) 
• JPEG (.jpg, .jpeg, .jpe, .jfif) 
• PNG (.png) 
• TIFF (.tif, .tiff) 

3.3 Running the Application 
There are three ways that the Crafty49’s Book Folding Pattern Maker application can be started: - 
 

1. Clicking on the desktop program icon (if created). 
2. From the start menu -> Programs -> Ideas R Us Software -> Crafty49’s Book Folding Pattern Maker -> 

Crafty49’s Book Folding Pattern Maker (if created). 
3. By clicking on the BookFolding.exe in the folder where the application was installed. The default is 

C:\Program Files\IdeasRUsSoftware\Crafty49sBookFoldingPatternMaker 
 
The main form will appear (see Picture 32 Screen Shot of the Crafty49’s Book Folding Pattern Maker). 
 
When the application is first run, there can be quite a long start up delay. After that, the start up will be much 
quicker. This will always be the case when the system is restarted. 

3.3.1 Expired or Invalid Licence 
The application requires a valid licence file (ending in *.licence), otherwise a pop-up will appear (see Picture 
5 Invalid Licence Pop-up). 
 

• Full release with hardware lock, runs on 2 computers per licence 
• Trial release with hardware lock an expiry date, runs on 1 computer per licence 
• Demo release with an expiry date, runs on any computer with licence 

 
Picture 5 Invalid Licence Pop-up 

 

3.3.2 Nag Screen 
This will only be seen with a Demo (un-licenced) version. 
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Picture 6 The Nag Screen for a Demo Release Version 

 

3.3.3 Licence the Full or Trial Application 
This requires Internet access, for either the ‘Licence a Product’ desktop application or manually via the Ideas R 
Us Software website (http://www.ideas-r-us-software.uk/). 
 
The Full and Trial release versions need to be licenced/activated first before they can be run. If not an Invalid 
Licence pop-up will appear (see Picture 5 Invalid Licence Pop-up). The Full and Trial versions are the same; 
it’s the licence file that will be different. 
 
Upgrading from a Trial to a Full licence requires the ‘Licence the Product’ application to be run again. 
 
The Licence a Product’ desktop application would have normally run when ‘Crafty49’s Book Folding Pattern 
Maker’ was first installed (see Picture 7 The Licence a Product Desktop Application), but it can be run any time 
after installation. 
 
Picture 7 The Licence a Product Desktop Application 

 
 
Enter the email address and password that was emailed to you after purchasing the software (the email address 
used for PayPal), or that you used to log into the Ideas R Us Software website if that has been changed. 
 
Click on the ‘Licence Product’ button. If the email address, password, product and hardware ID are valid, then 
after a short delay, the message box will be displayed (see Picture 8 Product Activated/Licenced Okay). 
Clicking ‘Ok’ will start ‘Crafty49’s Book Folding Pattern Maker’ and verify that the licence is valid/correct. 
 

http://www.ideas-r-us-software.uk/
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Picture 8 Product Activated/Licenced Okay 

 
 

3.3.3.1 More than One Licence for the Product 
If there is more than 1 licence, such as a Trial and Full version, a message box will be displayed (see Picture 9 
More than One Licence). 
 
Picture 9 More than One Licence 

 
 
Clicking ‘Ok’ will display the ‘Can Licence Products’ drop down list for the product and the hardware ID (see 
Picture 10 Available Licences for ).  
 
Picture 10 Available Licences for Crafty49’s Book Folding Pattern Maker 

 
 
The current hardware ID (see Picture 7 The Licence a Product Desktop Application) is not in the ‘Can Licence 
Products’ list, since there can only be one hardware ID for that email address/account and software product. 
The hardware ID is unique for each computer. 
 

• 21 is the licence ID 
• BFV1FULL is the code for ‘Crafty49’s Book Folding Pattern Maker’ 
• ‘####-####-####-####-####’ indicates a licence that is not activated, it can be used with any hardware 

ID (2 for Full versions, and 1 for Trial versions) 
• ‘3950-1AC3-E3DF-AB5A-73DC’ indicates a licence that has been activated with that hardware ID 

 
The current hardware ID cannot overwrite a different hardware ID in a licenced product. 
 
Select a product to licence from the list, click the ‘Licence Product’ button, and then after a short delay a 
message box will appear (see Picture 8 Product Activated/Licenced Okay). Clicking ‘Ok’ will start ‘Crafty49’s 
Book Folding Pattern Maker’ and verify that the licence is valid/correct. 

3.3.3.1.1 Error Messages 
 

• No product has been found to register. The application will close. 
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• Cannot create the hardware ID. Please try again. 
• The network connection is not available. 
• The email address has too few characters. 
• The password has too few characters. 
• The login email address or password is not correct. 
• Cannot connect to the Licensing Server. Please try again later. 
• There are no licenced products. 
• Cannot get a licence file. 
• Error reading from the database. 

3.3.3.2 Manually Licence a Product 
This would normally be done when the computer that a product is to be used on has no Internet connection. 
 
Find out where ‘Crafty49’s Book Folding Pattern Maker’ was installed (see 3.3.4 Folder Locations for the 
Licence File), and start the ‘LicenceAProduct.exe’ application. You need this to create the hardware ID string 
that is going to be used via the Ideas R Us Software website. 
 
Enter an email address, and a password (doesn’t have to be the correct one), and then click on the ‘Licence 
Product’ button. An error message will appear, click ‘Ok’ and the ‘Manually Licence a Product Information’ 
button appears (see Picture 11 The Licence a Product Desktop Application with Manually Licence Product 
Button). 
 
Picture 11 The Licence a Product Desktop Application with Manually Licence Product Button 

 
 
Click the ‘Manually Licence a Product Information’ button, a form will appear (see Picture 12 The Manually 
Licence a Product Information Box) select and copy the Hardware ID string (or all the information), and save it 
to a file on removable media. You could write down the hardware ID string as well. 
 



Crafty49’s Book Folding Pattern Maker User Guide V1.1.00 
 

Page 26 

Picture 12 The Manually Licence a Product Information Box 

 
 

• Go to the Ideas R Us website (http://www.ideas-r-us-software.uk/), and login using the email and 
password that was sent to you after you purchased the software (the email address used for PayPal), or 
that you used to log into the Ideas R Us Software website if that has been changed. 

• Scroll down to the Licences section (See Picture 13 The Licences Section) 
• Click on the link ‘Manually Licence Products’ 

 
Picture 13 The Licences Section 

 
 

• Select the product to licence (see Picture 14 The Manually Licence a Product Web Page) 
• Enter the hardware ID string from the ‘Manually Licence a Product Information’ box 
• Click on the button ‘Get Licences for Hardware ID’ 

 

http://www.ideas-r-us-software.uk/
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Picture 14 The Manually Licence a Product Web Page 

 
 
 
There will be one or more licences. Select the licence required, and then click on the button ‘Licence and 
Register Product’ (see Picture 15 The Manually Licence a Product Web Page with Licences). 
 
Picture 15 The Manually Licence a Product Web Page with Licences 

 
 
To save the licence file, click on the Licence Download Link (see Picture 16 The Manually Licence a Product 
Web Page with a Licence File Link). 
 
Picture 16 The Manually Licence a Product Web Page with a Licence File Link 

 
 
Click the ‘Ok’ (Firefox, Picture 17 File Download Dialogue in Firefox) or the ‘Save’ (Internet Explorer, Picture 
18 File Download Dialogue in Internet Explorer) button. 
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Picture 17 File Download Dialogue in Firefox 

 
 
Picture 18 File Download Dialogue in Internet Explorer 

 
 
Navigate to the removable media device, and change the licence filename to BookFoldingV1.licence, and 
click the ‘Save’ button (see Picture 19 Save Licence File as Dialogue Box). 
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Picture 19 Save Licence File as Dialogue Box 

 
 
On the computer with the product to licence, copy the BookFoldingV1.licence file to the Installation folder, 
and overwrite the existing licence file. Start ‘Crafty49’s Book Folding Pattern Maker’ to verify that the licence 
is valid/correct. 

3.3.3.2.1 Error Messages 
 

• The hardware ID is not in the correct format, correct length, or invalid. Please enter again. 
• Cannot read any licences from the database. 
• Cannot get a licence file. 
• The licence file cannot be saved. 

3.3.4 Folder Locations for the Licence File 
Their location depends on the Operating System. 
 
The Licence File can be viewed from the Help -> Installation Folder (see 5.3.2 Installation Folder) menu. 
 
Picture 20 Help Menu 

 
 
If the ‘Start Menu’ (see Picture 21 Start Menu Entry for Crafty49’s Book Folding Pattern Maker) was selected 
during install (not for Windows 8.x), then the folders can be accessed by clicking on the folder link. ‘Crafty49’s 
Book Folding Pattern Maker Folder’ for the licence file. 
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Picture 21 Start Menu Entry for Crafty49’s Book Folding Pattern Maker 

 

3.3.4.1 Licence File 
The licence file (*.licence) for a Demo, a Full or a Trial version is in the same folder where the application is 
installed. 
 
For 32-bit Operating Systems, the default location is: - 
 

C:\Program Files\IdeasRUsSoftware\Crafty49sBookFoldingPatternMakerDemo 
C:\Program Files\IdeasRUsSoftware\Crafty49sBookFoldingPatternMakerFull 

 
For 64-bit Operating Systems, the default location is: - 
 

C:\Program Files (x86)\IdeasRUsSoftware\Crafty49sBookFoldingPatternMakerDemo 
C:\Program Files (x86)\IdeasRUsSoftware\Crafty49sBookFoldingPatternMakerFull 
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3.4 Quick Start Guide for Creating a Book Folding 
Pattern 
This what the main form looks like after starting. 
 
Picture 22 The Main Form 

 
 
To create a book-folding pattern: - 
 

1. Enter the Pattern Details 
2. Load and Adjust the Image 
3. Change the Book Details 
4. Adjust the Margins and Spacing (if enable) 
5. Create the Pattern 
6. Print the Pattern 
7. Save the Pattern, for Full/Trial Versions Only, and if required to do so. 

 
Steps 1 to 4 can be carried out in any order. 
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Picture 23 After a Book Folding Pattern has been Created 

 

3.4.1 Enter the Pattern Details 
• Choose the Pattern Type 
• Choose the Units (for book height and pattern measurements) 
• Enter the Pattern Name, Author, Website, Copyright and Comments (not required to create a pattern) 

 
Picture 24 The Pattern Details 

 
 
See section 8.1 Pattern Details for more details. 
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3.4.2 Load and Adjust the Image 
 

Menu -> File -> Open… Ctrl + O 
Menu -> Edit -> Paste Ctrl + V 
 
There are 3 ways to load a bitmap/raster image: - 
 

1. From the File Menu, Menu -> File -> Open… 
2. Drag and Drop a File onto the Original Image, from Explorer or another File Viewer 
3. Copy and Paste an Image, e.g. Microsoft Paint, Menu -> Edit -> Paste 

 
Most of checkboxes can be left un-ticked. 
 

• Image Threshold, the Default Value of 0.5 is Correct for Most Images 
• Remove Space Around Image, Mainly to Prevent Unwanted Blank Leaves at the Front and End of the 

Pattern  
• Remove Space Between Shapes, Mainly for Mark and Fold Patterns 
• Invert Image Colours, make the Image Negative 
• Mirror Image Horizontally 
• Mirror Image Vertically 

 
Picture 25 The Original Image Details 

 
 
See section 8.2 Original Bitmap or Raster Image for more details. 
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3.4.3 Change the Book Details 
 

• Enter the number of Book Leaves (this is fixed at 75 for the Demo version) 
• Enter the Book Height, in cm or mm, Depends on the Units Setting 
• Enter the Minimum Distance Between Marks, in cm or mm (can be left as it is) 
• Choose the Fold/Page Numbering details for the pattern 

 
The Actual Book Leaves, Actual Book Pages and Marking Points (for Cut and Fold) will change after the 
pattern is created. 
 
Picture 26 The Book Details 

 
 
See section 8.4 Pattern Settings for more details. 

3.4.4 Adjust the Margins and Spacing 
This is enabled if the Remove Space Around Image check box is ticked in Original Image group. The default 
settings can be used. 
 
The Use Folds Between Pattern (or pages) checkbox is enabled if the Pattern Type is ‘Cut and Fold’. 
 

• Enter the Leaves Before Pattern, Mainly for Cut and Fold Patterns 
• Enter the Leaves After Pattern, Mainly for Cut and Fold Patterns 
• Enter the Top Margin, in cm or mm 
• Enter the Bottom Margin, in cm or mm 

 
The changes made will only appear on the Pattern Image, after the Create Pattern is clicked (see 3.4.5 Create 
the Pattern). 
 
Picture 27 The Margins and Spaces Details 

 
 
See section 8.4.5 Margins and Spaces for more details. 

3.4.5 Create the Pattern 
 

 
Clicking the Create Pattern button will create the pattern and Pattern Image. 
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Picture 28 The Pattern Image Preview 

 
 
Keep on adjusting the Image Properties, the Book Leaves, and the Margin and Spaces until it looks right. 
 
See section 8.5 Create Pattern Button for more details. 

3.4.6 Printing the Pattern 
 

Menu -> File -> Print Preview… 
Menu -> File -> Print… Ctrl + P 
 
Only after the Create Pattern button is clicked, is it possible to Print Preview or Print the pattern. 
 
First use the page set-up, Menu -> File -> Page Setup… 
 
If this is not set correctly, some of the details in printed output and the PDF file may be missing. Set the Left, 
Right, Top and Bottom margins to 10mm or smaller. 
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Picture 29 The Page Set-up Form 

 
 
Selecting either the Print Preview or Print (from the File menu or Toolbar buttons) will show the Set Marking 
Pattern Type Form first (see Picture 30 The Set Marking Pattern Type Form). 
 
For most patterns, the Pattern Chart settings can be left at the default values. The settings are temporary 
remembered. 
 

• Set the PDF/Print/Preview Pattern Type 
• The Pattern Chart Section is Only Enabled if Chart or Chart and Measure is Selected 
• Set the DPI, to Increase the Chart Quality, Especially the Fold/Page Numbers 
• Set the Fold/Page Numbers Positions, or Have None 
• Tick the Set Page Size to Use a Fixed Paper Size and Orientation  
• The Chart Line Spacing/Line Width 
• Show Centre Lines Centre Line Width 
• Set Page Size (Only if Set Page Size it Ticked) 
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Picture 30 The Set Marking Pattern Type Form 

 
 
See sections 5.1.3 Page Setup, 5.1.4 Print Preview, 5.1.5 Print, and 7.1 Set Marking Pattern Type Form for 
more details. 

3.4.7 Save the Pattern 
 

Menu -> File -> Save Pattern Files As… Ctrl + Shift + S 
 
This is for Full and Trial versions only. 
 
It is not necessary to save the pattern files, since they cannot be edited at this moment in time. 
 
Only after the Create Pattern button is clicked, is it possible to save a pattern. 
 
This will show the Set Marking Pattern Type form first (see Picture 30 The Set Marking Pattern Type Form). 
 
Navigate to your saved patterns folder, and enter a file name and click the save button. This will create a 
number of files. 
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Picture 31 The Save Pattern Files As Form 

 
 
See section 8.6.1 Saving the Pattern Files for more details. 
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4. Main Form Overview  
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This is the main form after starting. 
 
Picture 32 Screen Shot of the Crafty49’s Book Folding Pattern Maker 

 

4.1 Drag and Drop a File 
Drag and Drop a file from a file viewer such as Explorer onto the form’s ‘canvas’. 
 

Select a file, then click and hold the mouse button. When the mouse is moved it will change to a  symbol 
(no drop). 

Drag the file onto the Crafty49’s Book Folding Pattern Maker ‘canvas’; the cursor will change to a  symbol 
(drop and copy). Release the mouse button and the image should appear in the ‘Original Image’. 
 
If the form’s ‘canvas’ is hidden, drag the file to the Crafty49’s Book Folding Pattern Maker task bar button. 
The form will now be visible. 
 
If the pattern files have not been saved, then a warning message will appear. Click ‘No’ to go back and save the 
pattern files, or ‘Yes’ to continue. 
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Picture 33 Warning of Unsaved Pattern Files 

 

4.2 Progress Bar 
When an operation is expected to take some time, the Progress Bar with moving blocks will be shown. 
Currently Print, Print Preview and Save Pattern Files As will display the progress bar. 
 
Picture 34 Progress Bar with Moving Blocks 
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5. Menu 
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• File Menu 
• Edit Menu 
• Help Menu 

 

5.1 File Menu 
Picture 35 File Menu Items with Disabled Items 

 
 

• Open 
• Save Pattern Files As 
• Page Setup 
• Print Preview 
• Print 
• Exit 

5.1.1 Open 
Menu -> File -> Open 
Ctrl + O 
Toolbar, see 6.2 Open Button 
 
Opens a raster image file. 
 
Clicking the item will show a standard Windows ‘Open File’ dialogue box. Select any supported raster file to 
load it. 
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Picture 36 Open an Image File 

 
 
If the pattern files have not been saved, then a warning message will appear. Click ‘No’ to go back and save the 
pattern files, or ‘Yes’ to continue. 
 
Picture 37 Warning of Unsaved Pattern Files 

 

5.1.1.1 Error Messages 
The file type is not supported. 
Error converting the image to greyscale. 

5.1.2 Save Pattern Files As 
Menu -> File -> Save Pattern Files As 
Ctrl + Shift + S 
Toolbar, see 6.3 Save Pattern Files Button 
 
This will be greyed out if no pattern files exist. 
 
Saves a set of pattern files to disk. The PDF file is created as an A4 or A3 page, but will be scaled when 
printed. Also see 8.6.1 Saving the Pattern Files. 
 
The ‘Set Marking Pattern Type’ will first appear. See 7.1 Set Marking Pattern Type Form. 
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Set the values then click the OK button to show the Save Pattern Files as dialogue form. 
 
Picture 38 The Set Marking Pattern Type Form 

 
 
Picture 39 Save the Pattern Files 
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Note: Patterns created with a large number of book leaves may take some time, and a Progress Bar will appear 
(see Picture 34 Progress Bar with Moving Blocks). 

5.1.2.1 Error Messages 
Error creating the pattern document. 
Error creating the preview image. 
Error saving the pattern files. 
The pattern chart cannot be created. 

5.1.3 Page Setup 
Menu -> File -> Page Setup 
 
This is the standard Windows Page Set-up form that sets the paper size, paper orientation, paper/printer margins 
and printer. 
 
If this is not set correctly, some of the details in printed output and the PDF file may be missing. Set the Left, 
Right, Top and Bottom margins to 10mm or smaller. 
 
Picture 40 Print Page Set-up Form 

 

5.1.4 Print Preview 
Menu -> File -> Print Preview 
Toolbar, see 6.4 Print Preview Button 
 
Is greyed out when there is no pattern files to print. 
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This is the standard Windows Print Preview form that shows what the patterns should look like when printed. 
This will also what the PDF file will look like when the patterns are saved (see 8.6.1.5 The Pattern PDF File). 
 
The ‘Set Marking Pattern Type’ will first appear. See 7.1 Set Marking Pattern Type Form. 
 
Set the values then click the OK button to show the Print Preview Form dialogue. 
 
Picture 41 The Set Marking Pattern Type Form 

 
 
Note: Patterns created with a large number of book leaves may take some time, and a Progress Bar will appear 
(see Picture 34 Progress Bar with Moving Blocks). 
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Picture 42 Print Preview Set-up Form (Shows the Mark and Fold Method Pattern) 

 

5.1.4.1 Error Messages 
Error creating the pattern document. 
Error creating the preview image. 
Error saving the pattern files. 
The pattern chart cannot be created. 

5.1.5 Print 
Menu -> File -> Print 
Ctrl + P 
Toolbar, see 6.5 Print Button 
 
Is greyed out when there is no pattern files to print. 
 
This is the standard Windows Print form where a printer can be selected. Make sure you’ve set it up correctly 
before clicking the ‘Print’ button. 
 
The ‘Set Marking Pattern Type’ will first appear. See 7.1 Set Marking Pattern Type Form. 
 
Set the values then click the OK button to show the Pint Form dialogue. 
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Picture 43 The Set Marking Pattern Type Form 

 
 
Note: Patterns created with a large number of book leaves may take some time, and a Progress Bar will appear 
(see Picture 34 Progress Bar with Moving Blocks). 
 
Picture 44 Print Form 
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5.1.5.1 Error Messages 
Error creating the pattern document. 
Error creating the preview image. 
Error saving the pattern files. 
The pattern chart cannot be created. 

5.1.6 Exit 
Menu -> File -> Exit 
Alt + F4 
 
Exit or closes the application. 
 
If the pattern files have not been saved, then a warning message will appear. Click ‘No’ to go back and save the 
pattern files, or ‘Yes’ to exit. 
 
Picture 45 Warning of Unsaved Pattern Files 

 

5.2 Edit Menu 

 
 

• Paste 

5.2.1 Paste 
Menu -> Edit -> Paste 
Ctrl + V 
Toolbar, see 6.6 Paste Button 
 
Pastes a copied raster image into the ‘Original Image’ picture box 
 
If the pattern files have not been saved, then a warning message will appear. Click ‘No’ to go back and save the 
pattern files, or ‘Yes’ to continue. 
 
Picture 46 Warning of Unsaved Pattern Files 
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5.3 Help Menu 

 
 

• User Guide 
• Installation Folder 
• Check for Updates 
• About 

5.3.1 User Guide 
Menu -> Help -> User Guide 
 
You are reading it! This will open the PDF User Guide. A PDF reader must be installed to view the User Guide; 
otherwise an error message will be displayed. 
 
It is located in the Installation Folder, or in the Documents sub-folder (see 5.3.2 Installation Folder). 

5.3.2 Installation Folder 
Menu -> Help -> Installation Folder 
 
This will open the folder where ‘Crafty49’s Book Folding Pattern Maker Folder’ is installed. If it cannot, an 
error message will be displayed. 
 
Picture 47 Installation Folder 

 
 

5.3.3 Check for Updates 
Menu -> Help -> Check for Updates 
Ctrl + U 
 
Checks if there is an update to the current application. 
 
The latest release/update is also available from the Ideas R Us Software website (www.ideas-r-us-software.uk), 
from the Downloads web page. 
 
If the version is up to date, the message box in Picture 48 The Current Version is up to Date will be displayed. 
 

http://www.ideas-r-us.co.uk/
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If there is an update available, the message box in Picture 49 There is a New Version Available will be 
displayed. 
 
If there is a problem with the network connection or the update server, the message box in Picture 50 Network 
Connection Problem or Picture 51 Update Server Problem will be displayed. 
 
Note: There may be a delay before a pop-up message box, or an error message appears. 
 
Picture 48 The Current Version is up to Date 

 
 
Picture 49 There is a New Version Available 

 
 
Picture 50 Network Connection Problem 

 
 
Picture 51 Update Server Problem 

 
 

5.3.3.1 Download the New Version 
To download the new version, click the ‘Yes’ button in Picture 49 There is a New Version Available, the ‘Save 
As’ dialogue box will appear (see Picture 52 Select the Location to Save the Set up File). Clicking the ‘No’ 
button will cancel the download. 
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Select the folder where the download file is to be saved (the file name can be renamed if required), then click 
the ‘Save’ button. After the file has finished downloading, a message will be displayed. Click the ‘OK’ button. 
 
Note: There is a short delay while the file is downloading. 
 
Picture 52 Select the Location to Save the Set up File 

 
 
Picture 53 The File has downloaded 

 

5.3.3.2 Installing the Update 
To install the update, the Crafty49’s Book Folding Pattern Maker application must be closed down. 
 
An installation guide is available if help if needed with the install. See the Downloads web page from the Ideas 
R Us website (www.ideas-r-us-software.uk). 

5.3.3.3 Other Error Messages 
These are system errors. 
 

• The version information on the server is incorrect. 
• The version infomation file on the server is missing. 
• The download link on the server is missing. 

http://www.ideas-r-us.co.uk/
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• The setup file on the server is missing. 
 
Note: Under certain conditions if the server is down or there is no network connection, these can also be 
displayed. 

5.3.4 About 
Menu -> Help -> About 
F1 
 
Shows the ‘Crafty49’s Book Folding Pattern Maker’, which is just version information, and where to report 
issues with the application. 
 
Picture 54 The ‘About’ Box for a Demo Version (Expiry Date Licence) 

 
 
For a registered full release version, the information is as shown below. 
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Picture 55 The 'About' Box for a Full Release Version (Hardware Lock Licence) 

 
 
For a registered Full Trial release version, the information is as shown below. 
 
Picture 56 The ‘About’ Box for a Full Release Trial Version (Hardware/Expiry Date Licence) 
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6. Tool Bars 
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6.1 Overview 
• Open 
• Save Pattern Files As 
• Print Preview 
• Print 
• Paste 

6.2 Open Button 
 

 
Opens a raster image file. 
 
Also see the menu item in 5.1.1 Open. 

6.3 Save Pattern Files Button 
 

 
Saves the created pattern files to disk. 
 
Also see the menu item in 5.1.2 Save Pattern Files As. 

6.4 Print Preview Button 
 

 
Previews the Marking Pattern and preview images to be printed. 
 
Also see the menu item in 5.1.4 Print Preview 

6.5 Print Button 
 

 
Prints the created Marking Pattern and preview images to the selected printer. 
 
Also see the menu item in 5.1.5 Print. 

6.6 Paste Button 
 

 
Pastes a copied clipboard raster image to the ‘Original Image’ picture box. Also see the menu item in 5.2.1 
Paste. 
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7. Settings 
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7.1 Set Marking Pattern Type Form 
Sets which marking pattern type or types will be in the PDF file or the print output. 
 
This will appear when selecting Print, Print Preview or Save Pattern Files as. 
 
The Chart images will also be saved when saving the pattern files (see 8.6.1 Saving the Pattern Files), even if 
the Chart option is not selected. 
 
Picture 57 Set Marking Pattern Type Form 

 

7.1.1 PDF/Print/Preview Pattern Type Group 
Select between Chart, Measure and Chart and Measure pattern types for the PDF or Print output. The methods 
can Cut and Fold or Measure and Fold. 

7.1.1.1 Pattern Chart Type 
Picture 58 Pattern Chart Type Setting 

 
 
This setting will create a Chart or Graph or Line or Stripe pattern that doesn’t require the marking points to be 
measured. See Picture 59 Chart Pattern Type for Cut and Fold and Picture 60 Chart Pattern Type for Measure 
and Fold. 
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Picture 59 Chart Pattern Type for Cut and Fold 

 
 
Picture 60 Chart Pattern Type for Measure and Fold 

 
 
The PDF and Printed output has these problems: - 
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• Not be accurate from the top of the page, due to printer margins and fold/page margins 
• The printer driver scales pattern to fit printer margins and page 
• The Pattern Chart image is stretched to fit on the page. 

7.1.1.2  Measure Type Pattern 
Picture 61 Measure Type Pattern Setting 

 
 
This setting will create a table of measuring values used to mark the cut/fold points. See Picture 62 Measure 
Pattern Type for Cut and Fold and Picture 63 Measure Pattern Type for Mark and Fold. 
 
Picture 62 Measure Pattern Type for Cut and Fold 
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Picture 63 Measure Pattern Type for Mark and Fold 

 

7.1.1.3 Chart and Measure Pattern Type 
Picture 64 Chart and Measure Type Pattern Setting 

 
 
This setting will create both a Chart and Measure Pattern type. See 7.1.1.1 Pattern Chart Type7.1.1.2 Measure 
Type Pattern. 

7.1.2 Pattern Chart Group 
The settings can only be changed when the Pattern Type is Chart or Chart and Measure. 

7.1.2.1 DPI 
 

 
This is the DPI (Dots per Inch) of the Chart image. 75 DPI is the lowest quality, with 600 DPI being the highest 
quality. 
 
Picture 65 The Image Chart DPI Setting 
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7.1.2.2 Fold/Page Numbers 

 
 
Sets the position of the Fold or Page numbers. The top and bottom numbers are rotated by 180 degrees to each 
other. 
 
Picture 66 Top/Bottom of Page 

 

Picture 67 Top/Bottom of Pattern Lines 

 

Picture 68 None 

 
 

7.1.2.3 Set the Page Size 
 

 
 
When the Set Page Size is not ticked, the Set Page Size options are disabled (see Picture 69 The Set Page Size 
Options are disabled). 
 
The Page Size and Orientation will be adjusted to fit the pattern height. 
 
Picture 69 The Set Page Size Options are disabled 

 
 
In Picture 70 Adjusting the Page Size and Orientation to fit on A4 Landscape, it shows the pattern height from 
the top of the book, to the bottom of the lines (the red dashed line) is 150mm. The book height is 297mm, 
which is the same size as an A4 Portrait page. The Pattern Chart won’t be on an A4 Portrait, since it will fit 
onto A4 Landscape. 
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Picture 70 Adjusting the Page Size and Orientation to fit on A4 Landscape 

 
 
The sequence of page size adjustment is: - 
 

• A4 Landscape, 297mm x 210mm 
• A4 Portrait, 210mm x 297mm 
• A3 Landscape, 420mm x 297mm 
• A3 Portrait, 297mm x 420mm 

 
Picture 71 Set Page Size Option Checked 

 
 
When the Set Page Size is ticked, the Set Page Size options are enabled. 
 
Picture 72 Set Page Size Option 

 
 
This does not fit the Chart Pattern to a single page, but will reduce the Chart Pattern height to fit the height of 
the page. The Line Spacing will be adjusted between 2 to 3mm, and there may be more than one page. 
 
It will not increase the pattern height to fit the page (see Picture 73 The Book Height 300mm Picture 74 300mm 
Chart Pattern on a A4 Landscape Page). 
 
If the book height were 300mm, it would normally require an A3 Landscape page. With A4 Landscape 
selected, the Chart Pattern height will be adjusted to fit on an A4 Landscape page (see Picture 74 300mm Chart 
Pattern on a A4 Landscape Page). The number of A4 pages used is dependant on the number of book leaves. 
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Picture 73 The Book Height 300mm 

 

Picture 74 300mm Chart Pattern on a A4 Landscape Page 

 

 
If the Book Height is smaller then the selected page size, the Chart Pattern is not adjusted to the height of the 
page (see Picture 76 175mm Chart Pattern on a A3 Portrait Page). The number of A3 pages used is dependant 
on the number of book leaves. 
 
Picture 75 The Book Height 175mm 

 

Picture 76 175mm Chart Pattern on a A3 Portrait Page 

 
 

 

7.1.2.4 The Line Spacing and Line Width 
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This can only be set when the Set Page Size is not ticked. 
 
This is the Line Spacing and Line Width between the Pattern Lines. The Line Spacing is from 2mm to 5mm, 
and the Line Width is from 0.5mm to 2mm. 
 
Picture 77 Line Spacing at 2mm 

 

Picture 78 Line Spacing at 5mm 

 
 
Picture 79 Line Width at 0.5mm 

 

Picture 80 Line Width at 2mm 

 
 

7.1.2.5 Show Centre Lines and Centre Line Width 
 

 
When the Show Centre Lines option is ticked, lines the full length of the pattern, from the top of the Pattern 
(see Picture 83 Centre Lines at the Top of the Pattern Chart), to the bottom of the Pattern (see Picture 84 Centre 
Lines at the Bottom of the Pattern Chart) will be drawn using the Centre Line Width value (from 0.1mm to 
0.5mm).  
 
Picture 81 The Show Centre Lines Option Ticked 

 
 
The Centre Line Width can only be changed when the Show Centre Line option is ticked. 
 
Picture 82 Centre Line Width Control 
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Picture 83 Centre Lines at the Top of the Pattern Chart 

 
 
Picture 84 Centre Lines at the Bottom of the Pattern Chart 

 

7.1.2.6 Known Issues 
 

• There may be only one Pattern Line on the page 
• The Pattern Chart isn’t centred 
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8. Group Panels 
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• Pattern Details 
• Original Image 
• Pattern Image 
• Book Details 

 
Changing any of the values in these group panels will disable the printing and saving functions until the pattern 
is created again. 
 
Picture 85 Screen Shot of the Crafty49’s Book Folding Pattern Maker 

 
 

8.1 Pattern Details 
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8.1.1 Pattern Type 
The pattern type can either be Cut and Fold (Measure, Mark, Cut and Fold) or Mark and Fold (Measure, Mark 
and Fold) method. 
 
Picture 86 The Pattern Type 

 

8.1.2 Units 
Selecting either cm (centimetres) or mm (millimetres) for the units will change the Book Height, Minimum 
Distance Between Marks, the Top and Bottom Margins, and the Marking Points on the pattern. 
 
Picture 87 The Units 

 

8.1.3 Other Pattern Details 
The Pattern Name, Author, Website, Copyright and Comments will be added to the printable or PDF file 
Pattern documents (see Picture 89 The Pattern Details from the Pattern Document). 
 
Picture 88 Pattern Name, Author, Website, Copyright, and Comments Details 

 
 
Picture 89 The Pattern Details from the Pattern Document 
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8.2 Original Bitmap or Raster Image 
This is the raster image file that is used to create the pattern files (see Picture 90 The Original Image for 
Creating Pattern Files). It is not the original source image or file, which may be in colour. 
 
Opening a file, dragging a file, or pasting a file will reset the Image Threshold to 0.5, and un-tick all the check 
boxes in the Original Image group box. 
 
Picture 90 The Original Image for Creating Pattern Files 

 

8.2.1 Image Width and Height 
The image’s width and height is displayed (see Picture 91 The Threshold at 0.5). 
 
The size of the original image will be scaled to the height (image height) and to the number of folds (image 
width) of the book. So a book pattern of 200mm high and 100 folds (200 pages) will be scaled to 200 pixels 
high by 100 pixels wide. 

8.2.2 Image Threshold 
Adjusting the threshold value will change the density of the image. A correct value can be around 0.5 (see 
Picture 91 The Threshold at 0.5), but this is not always the case. 
 
If the value is too low, the image will be light and have no fill (see Picture 92 The Threshold at 0.01). 
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If the value is too high, the image will have the very light areas becoming dark, or the entire image will be 
black (see Picture 93 The Threshold at 1.0). 
 
Picture 91 The Threshold at 0.5 

 
 
Picture 92 The Threshold at 0.01 
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Picture 93 The Threshold at 1.0 

 

8.2.3 Remove Space Around Image 
 

 
 
When ticked, all the space around the black is removed (see Picture 95 After Space has been removed around 
the Image). 
 
Picture 94 Before the Space has been removed around the Image 

 
 
Picture 95 After Space has been removed around the Image 

 
 

8.2.4  Remove Column Space Between Shapes 
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Blank (non-black) columns will produces patterns that have blank or unfolded book leaves. In most cases this is 
not required, but in some it is. Checking or ticking the ‘Remove Column Space Between Shapes’ will remove 
any blank column from between the black parts of the image. See Picture 97 After Column Space Between 
Shapes has been removed. 
 
This may not be always desirable. In Picture 97 After Column Space Between Shapes has been removed, both 
the letters ‘L’ in ‘Hello’ have been merged together. 
 
Picture 96 Before Column Space Between Shapes has been removed 

 
 
Picture 97 After Column Space Between Shapes has been removed 

 
 

8.2.5 Invert Image Colours 
When ticked, the image colours are inverted (made negative), black becomes white, and white becomes black. 
 

 
 
Picture 98 The Image with the Colours Inverted 

 

8.2.6 Mirror Image Horizontally 
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When ticked, the image is mirrored or flipped about the horizontal axis. 
 
Picture 99 The Image Mirrored Horizontally 

 

8.2.7 Mirror Image Vertically 
 

 
 
When ticked, the image is mirrored or flipped about the vertical axis. 
 
Picture 100 The Image Mirrored Vertically 

 

8.2.8 Error Messages 
Error adjusting the image threshold. 
Error removing space from around the image. 
Error processing the image. 
Error removing columns from the image. 
Error inverting the image. 

8.3 Pattern Image 
 

 
 

• Cut and Fold (is Measure, Mark, Cut and Fold) 
• Mark and Fold (is Measure, Mark and Fold) 

 
This does not show what the finished width of the folded book will look like, since: - 
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• The number of fold/pages 
• Depends on how tightly the folds are made 
• How flat the folds lie 
• How much the book is ‘squished’ (flattened) 

 
See also Picture 103 The Effects of Reducing the Pattern Preview Image (Mark and Fold). 

8.3.1 Cut and Fold Method 
This is created after the ‘Create Pattern’ button has been clicked. The blue lines are blank folds; see Picture 101 
The Created Pattern Image (Cut and Fold). 
 
Picture 101 The Created Pattern Image (Cut and Fold) 

 

8.3.2 Mark and Fold Method 
This is created after the ‘Create Pattern’ button has been clicked. The blue lines are blank folds, and the red 
lines are ‘alternate folds (see Picture 102 The Created Pattern Image (Mark and Fold).  
 
Picture 102 The Created Pattern Image (Mark and Fold) 
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Picture 103 The Effects of Reducing the Pattern Preview Image (Mark and Fold) 

 

8.4 Pattern Settings 
The Pattern Settings default values are below when the application is first started. 
 
Picture 104 Pattern Settings 

 

8.4.1 Book Leaves 
This is the number of required book leaves, but more or less can be created. 
 
The values are from 10 to 1,000 inclusive. 
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A book leaf is not the same as a book page. A book leaf has two sides or two pages. 
 
The higher the number of book leaves, the finer the pattern, but the longer it will take to fold or cut and fold. 
 
The Actual Book Leaves may not be the same as the required number of book leaves, see Picture 105 Book 
Parameters and Actual Used Book Folds and Pages. 
 
Picture 105 Book Parameters and Actual Used Book Folds and Pages 

 

8.4.1.1 Cut and Fold Only 
The Cut Points are the number of cuts to be made. This number is also in the Pattern Details Document Table; 
see Picture 137 The 1st Page of the Pattern Document (Cut and Fold). 
 

 

8.4.1.2 Mark and Fold Only 
If the book contains 300 pages, then set the Book Leaves to half of that, or 150. The final number of book pages 
is dependant on whether the image produces ‘alternate’ folds. 
 
Normally there are only two folds per book leaf, one at each corner. If a line through the drawing is split into 
two or more parts (the centre of the letter ‘O’ for instance), each of the lines will be folded onto alternate book 
leaves. See the red lines in the pattern preview for Picture 127 The Pattern Preview Image Showing Alternate 
Folds in Red (Mark and Fold). 
 
The Marking Points are the number folds to be made. This number is also in the Pattern Details Document 
Table; see Picture 140 The 1st Page of the Pattern Document (Mark and Fold). 
 

 

8.4.2 Book Height 
This is the height of the book, which is parallel to the book’s spine. 
 
The values are from 5 to 40cm or 50 to 400mm inclusive. 

8.4.3 Minimum Distance Between Marks 
The minimum distance between pairs of marking points, or the minimum length of the vertical black and red 
lines on the Pattern Preview image. For Cut and Fold, it is also the minimum gap between two vertical black 
lines. 
 
A value of 1mm will exclude all that are 1mm or less. Increasing this value will reduce the number of folded 
pages, and the level of detail. 
 
The values are from 0.1cm to 1cm or 1 to 10mm inclusive. 
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8.4.3.1 Cut and Fold 
For the Cut and Fold method, the lines can be merged. 
 
When set to 2mm, the lines are merged. This can produce a distorted image see Picture 107 The 1mm Lines are 
merged to into 1 2mm Line. 
 
Picture 106 An Image with 1mm White Line 

 
 
Picture 107 The 1mm Lines are merged to into 1 2mm Line 

 

8.4.4 Fold and Page Numbering 
The Pattern Files numbering can be set to either Folds or Pages. 
 
When Fold numbering is used, the sequence is all the numbers, e.g. 1, 2, 3, 4… 
 
When Page numbering is used, the sequence will be odd, e.g. 1, 3, 5, 7… 
 
The Start number is fold/page start sequence. The minimum value is 1, and the maximum value is 25% of the 
required Book Leaves (see 8.4.1 Book Leaves). 
 
A book with 100 folds or 200 pages will have a maximum Start value of 25 folds, or 50 pages. 
 
For Page numbering, the Start number is odd (1, 3, 5, etc). 
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Picture 108 Fold and Page Numbering 

 

8.4.5 Margins and Spaces 
This is only active when the ‘Remove Space Around Image’ check box is ticked (see 8.2.3 Remove Space 
Around Image). Changes to the Leaves Before, Leaves After, Top Margin, Bottom Margin, and Folds Between 
Pattern will only appear in the Pattern Image picture box (not the Original Image), when the ‘Create Pattern’ 
button is clicked. 
 
Picture 109 Margins and Spaces (Mark and Fold) 

 
 
Picture 110 The Original Image after the Space Around has been removed 

 

8.4.6 Leaves Before and After Pattern 
These are the unmarked or uncut leaves (they may also be folded) before or after the pattern image. This does 
not change the required number of Book Leaves. 
 
The minimum values are 0, and the maximum values are 25% of the required Book Leaves (see 8.4.1 Book 
Leaves). 
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Picture 111 The Pattern Image with Leaves Before and After the Pattern 

 

8.4.7 Top and Bottom Margins 
This is the space that is added to the Top and Bottom of the pattern image. 
 
The minimum values are 1.3cm (13mm), and the maximum values are 25% of the Book Height (see 8.4.2 Book 
Height). 
 
Picture 112 The Pattern Image with Top and Bottom Margins 

 

8.4.8 Use Folds Between Pattern (Cut and Fold) 
This will only be enabled with the Cut and Fold Pattern Type (see 8.1.1 Pattern Type). 
 
Normally the page is folded down to add some ‘bulk’ or ‘fill’ to the pattern. In Picture 113 The Book on the 
Left uses Folds between the Pattern by Chris Ashworth ©2016, the book on the left uses folds between the 
pattern, whilst the book on the right does not. 
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Picture 113 The Book on the Left uses Folds between the Pattern by Chris Ashworth ©2016 

 
 
When use folds option is ticked, the pattern image becomes grey (see Picture 115 With Folds Between the 
Pattern Image). 
 
Picture 114 No Folds Between the Pattern Image 
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Picture 115 With Folds Between the Pattern Image 

 
 
On the created patterns (Print or PDF) they are indicated by the abbreviation SF (Spacer Folds) for both the 
Chart and Table patterns. 
 
Picture 116 Spacer Folds on a Chart Pattern 

 
 
Picture 117 Spacer Folds on a Table Pattern 

 

8.5 Create Pattern Button 
The Pattern Preview Images will be different depending if the pattern type is Cut and Fold or Mark and Fold 
(see 8.1.1 Pattern Type). 
 
Click on the ‘Create Pattern’ button, and the preview pattern image and actual or calculated book folds/pages 
used are created. 
 
The thin black rectangle is the preview pattern image’s border, the black lines are the normal folds, and the blue 
lines are blank or un-folded leaves. 
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Picture 118 The Pattern Preview Image Showing Un-folded Leaves in Blue in the Centre 

 
 
The ‘ticking’ of the ‘Remove Column Space Between Shapes’ and ‘Min Distance Between Marks’ affects the 
Pattern Image after the ‘Create Pattern’ is clicked. 
 
In Picture 120 Original Image with Thin Black Line of Less than 1mm, the width of the line is less than 1mm. 
This setting will remove the line and replace it with blank leaves/pages (indicated by the blue lines) as shown in 
Picture 121 Pattern Image with the Thin Line Removed. 
 
Picture 119 Minimum Distance Between Marks 

 
 
Picture 120 Original Image with Thin Black Line of Less than 1mm 

 
 
Picture 121 Pattern Image with the Thin Line Removed 

 
 
If ‘Remove Column Space Between Shapes’ is ticked, then the pattern image will have the blank leaves 
removed as shown in Picture 122 Pattern Image with the Thin Line Removed and Blank Leaves Removed. 
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Picture 122 Pattern Image with the Thin Line Removed and Blank Leaves Removed 

 
 
Note: - With a high number of ‘Book Leaves’, the preview pattern image may appear to have missing lines. 
This is due to the scaling of the preview image. The saved preview pattern image will be correct. 

8.5.1 Cut and Fold Method 
For the Cut and Fold setting, when the Actual Book Leaves is different from the required Book Leaves, a pop 
message appears as in Picture 123 The Book Pages required Have Increased (Cut and Fold) or Picture 124 The 
Book Pages required have decreased (Mark and Fold), and the text ‘Actual Book Leaves’ turns to red (see 
Picture 105 Book Parameters and Actual Used Book Folds and Pages). 
 
It may be possible to create the exact number by either increasing or decreasing the book leaves and creating 
the preview pattern again. 
 
Picture 123 The Book Pages required Have Increased (Cut and Fold) 

 
 
Picture 124 The Book Pages required have decreased (Mark and Fold) 

 
 
The blue lines are the blank or un-folded book leaves. For the start and end of the book, these can be left in, but 
if they are in the middle for example, the 3-D effect will not be as good (see Picture 118 The Pattern Preview 
Image Showing Un-folded Leaves in Blue in the Centre). The Original Image will have to be edited, see 8.2.3 
Remove Space Around Image and 8.2.4 Remove Column Space Between Shapes. 
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Picture 125 The Pattern Preview Image Showing Blank Folds in Blue (Cut and Fold) 

 

8.5.2 Mark and Fold 
For the Mark and Fold setting, when the Actual Book Leaves exceeds the required Book Leaves, a pop message 
appears as in Picture 126 The Book Pages set Have Increased (Mark and Fold), and the text ‘Actual Book 
Leaves’ turns to red (see Picture 105 Book Parameters and Actual Used Book Folds and Pages). 
 
If ‘alternate’ folds have been produced, then the book leaves and total book pages may have been increased or 
decreased. It may be possible to create the exact number by either increasing or decreasing the book leaves and 
creating the preview pattern again. 
 
Picture 126 The Book Pages set Have Increased (Mark and Fold) 

 
 
The red lines are the ‘alternate’ folds (see Picture 127 The Pattern Preview Image Showing Alternate Folds in 
Red (Mark and Fold)). There can only be 2 folds per book leaf. 
 
The blue lines are the blank or un-folded book leaves. For the start and end of the book, these can be left in, but 
if they are in the middle for example, the 3-D effect will not be as good (see Picture 118 The Pattern Preview 
Image Showing Un-folded Leaves in Blue in the Centre). The Original Image will have to be edited, see 8.2.3 
Remove Space Around Image and 8.2.4 Remove Column Space Between Shapes. 
 
Picture 127 The Pattern Preview Image Showing Alternate Folds in Red (Mark and Fold) 
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8.5.3 Error Messages 
Error creating the pattern from the image. 
Error creating the preview image. 
Error creating the preview image. Too many alternate pages? 
Error creating the pattern from the image. 

8.6 Printing and Saving the Pattern Files 
The pattern file set consists of: - 
 

• *.-Original.png 
• *-Pattern.png 
• *-Pattern.csv 
• *.pdf 
• *.-P*.png 

 
The PDF file is a formatted document that contains the ‘*.-Original.png’, ‘*.-Pattern.csv’ , ‘*.-
Pattern.png’ and ‘*.-P*.png’ files. 
 
The other files can be used to create a custom layout using a desktop publishing package or a Word Processing 
package. 
 
Note: Patterns created with a large number of book leaves may take some time, and a Progress Bar will appear 
(see Picture 34 Progress Bar with Moving Blocks). 

8.6.1 Saving the Pattern Files 
Clicking the toolbar button  or clicking the menu item Save Pattern Files as from File, will display the Save 
Pattern Files dialogue box (see Picture 128 The Save Pattern Files As Dialogue Popup). 
 
The pattern files are the pattern preview image and the pattern-marking list, as well as a PDF document file. 
The file name is the base file name, and a suffix of ‘*.-Original.png’, ‘*.-Pattern.csv’ , ‘*.-
Pattern.png’ and ‘*.-P*.png’ will be added. 
 
Clicking the ‘Save’ button saves the set of pattern files to disk. Any existing files will be over written without 
warning. A pop-up message box will be displayed if the patterns have been saved okay (see Picture 129 Pattern 
Files Saved Okay), or if there is an error saving the files. 
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Picture 128 The Save Pattern Files As Dialogue Popup  

 
 
Picture 129 Pattern Files Saved Okay 

 
 

8.6.1.1 Original Image File 
The Original Image file (‘filename-Original.png’) is the same as displayed in the Original Image group 
panel (see Picture 130 Original Image), and not the image file that was opened or pasted. 
 
Picture 130 Original Image 
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8.6.1.2 Pattern Preview Image File 
The Pattern Preview Image file (‘filename-Pattern.png’) is the same as displayed in pattern preview group 
panel (see 8.3 Pattern Image) but with a lot more detail, and no coloured lines. 
 
Picture 131 Pattern Preview Image (Cut and Fold) 

 
Picture 132 Pattern Preview Image (Mark and Fold) 

 

8.6.1.3 Pattern Marking List File 
This can be used in a Spread Sheet application such as Microsoft’s Excel to create a custom formatted set of 
cutting or marking points. 
 
The Pattern Marking List CSV file (filename-Pattern.csv) consists of the header, and the cut or fold 
marking points. 
 
The Header contains: - 
 

• The ‘Page’ is the book page; it can also be ‘Fold’. 
• The ‘Cutting Points’ (Cut and Fold) 
• The ‘Top’ fold is the marking point in mm measured from the top of the book page (Mark and Fold). 
• The ‘Bottom’ fold is the marking point in mm measured from the top of the book page (Mark and Fold). 

 
Spacer folds for Cut and Fold will have SF in the Cutting Points column (see Picture 133 Pattern Marking List 
Showing the Header and Marking Points (Cut and Fold)). 
 
Blank or not folded leaves will not have any cutting or marking points in the fold columns (see Picture 134 
Pattern Marking List Showing the Header and Marking Points (Mark and Fold)). 
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Picture 133 Pattern Marking List Showing the Header and Marking Points (Cut and Fold) 

 
 
Picture 134 Pattern Marking List Showing the Header and Marking Points (Mark and Fold) 
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8.6.1.4 The Pattern Chart Image File(s) 
These are always created when the pattern files are saved, and depending if the Chart Pattern Type option was 
selected, may not be in the PDF file. See 7.1 Set Marking Pattern Type Form. 
 
The pattern chart images(s) will have a file name of ‘filename-Px.png’, where ‘Px’ is the page number 
starting at 1. If the Measure Pattern Type option is selected, the default or previous settings for the Chart 
Pattern will be used. 
 
Any existing files matching the file name filename-Px.png’ will be deleted first. An existing 3-page image 
pattern may have been changed to fit on 2 pages, and page 3 isn’t wanted. 
 
The red line indicates the top of the pattern. 
 
Picture 135 Cut and Fold Pattern Chart Image 

 
 



Crafty49’s Book Folding Pattern Maker User Guide V1.1.00 
 

Page 92 

Picture 136 Mark and Fold Pattern Chart Image 

 

8.6.1.5 The Pattern PDF File 
This is a pre-formatted document file that contains the pattern details, the original image, the pattern preview 
image, and a table of cutting or marking points. It is a quick and easy way to produce patterns for selling or 
distribution. 
 
The ‘Date Created’ is the current time of the computer (see Picture 137 The 1st Page of the Pattern Document 
(Cut and Fold)). 
 
The Cut and Fold or Mark and Fold PDF’s are very similar. 
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Picture 137 The 1st Page of the Pattern Document (Cut and Fold) 
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Picture 138 The 2nd Page of the Pattern Document (Cut and Fold) 
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Picture 139 The Marking Points Page of the Pattern Document (Cut and Fold) 
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Picture 140 The 1st Page of the Pattern Document (Mark and Fold) 
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Picture 141 The 2nd Page of the Pattern Document (Mark and Fold) 
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Picture 142 The Marking Points Page of the Pattern Document (Mark and Fold) 

 
 

8.6.2 Printing the Pattern Files 
To print the created pattern, see 5.1.3 Page Setup, 5.1.4 Print Preview, and 5.1.5 Print 
 
To print PDF files, a PDF reader must be installed. A PDF reader can be downloaded from Adobe’s website 
http://get.adobe.com/reader/otherversions/. 
 
Some modern Internet browsers will read PDF files. 

8.6.3 Error Messages 
Error creating the preview image. 
Error creating the preview image. Too many alternate pages? 
Error creating the pattern document. 
Error creating the PDF file. 
The pattern document cannot be previewed or printed. 
Error saving the pattern files. 

http://get.adobe.com/reader/otherversions/
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9. Tutorials 
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9.1 Good and Bad Image Files to Use 
9.1.1 Cut and Fold 

• All the images for Mark and Fold are good images to use 
• Too little contrast, the pattern cannot be seen against the background 
• Too much detail, some of the fine lines will be lost 
• Bad images 

o Chequered squares/dots 
o Lots of fine lines, can be removed during ‘Create Pattern’ 

 
Table 1 Images not Suitable for Cut and Fold 

Original – Dashed Lines Pattern – Dashed Lines Original – Heart Outline Pattern – Heart 
Outline 

  
  

 

9.1.2 Mark and Fold 
• Too little contrast, the pattern cannot be seen against the background 
• Too much detail, some of the fine lines will be lost 
• Too many holes will create too many alternate folds 

 
All the images and patterns below (see Table 2 Images and the Patterns Created from them) had the column 
space removed, and had 150 book leaves (300 pages). 
 
The best image to use is the Heart, with only a few alternate folds. The least suitable image is the Tree and 
Winding Path, with mostly alternate folds, and gaps white gaps between the alternate folds. 
 
Increasing the number of book leaves used, may improve the look of the folded book for the Tree and Winding 
Path pattern. The only way to be sure is to fold a book from the pattern. 
 
All the images are from the Webdings, from Microsoft. 
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Table 2 Images and the Patterns Created from them 

Original – Heart Pattern - Heart Original – Alien Head Pattern – Alien Head 

    
Original - Lips Pattern - Lips Original – Musical 

Note Pattern – Musical Note 

  

  
Original – Tree and 

Winding Path 
Pattern – Tree and 

Winding Path   
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9.2 Creating an Image File Using MS Paint 
In this tutorial, a single letter will be created using the built in fonts. 
 
Start the Paint application, Start -> Programs -> Accessories -> Paint 
 
Set the image size to say 3” x 3”, Menu -> Image -> Attributes (see Picture 143 Image Attributes) 
 
Click ‘Yes’ to the pop up ‘Converting to black and white cannot be undone’ (see Picture 144 Warning Message 
about Changing from Colour to Black and White). 
 
Picture 143 Image Attributes 

 
 
Picture 144 Warning Message about Changing from Colour to Black and White 
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Picture 145 The Blank Canvas 

 
 
Click on the Text icon ‘ ’ on the tool panel to select Text mode, and click on the top left corner of the white 
canvas. A flashing cursor will appear. Adjust the font size to 150 pixels, select a font style, and decoration 
(bold, italic, underline). 
 
The text toolbar should appear, if not, click Menu -> View -> Text Toolbar (see Picture 146 The Text Toolbar). 
 
Select the Text icon again, and click on the top left corner, the marquee (dashed line) will be resized. 
 
Picture 146 The Text Toolbar 

 
 
Click onto the canvas, and type a letter, this will appear on the canvas. 
 
Picture 147 The Typed Letter 

 
 
The letter is in the wrong place and has too much white space. 
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To move the letter, click on the marquee icon  on the tool panel, and drag the marquee as close to the letter 
as possible. Move the selected letter to where you want (a 4-headed arrow will appear when the cursor is in the 
marquee area). See Picture 148 The Letter Moved to the Top Left. 
 
Picture 148 The Letter Moved to the Top Left 

 
 
To remove the excess white from the right hand side and the bottom, either change the size of the image 
attributes (see Picture 143 Image Attributes above), or drag the bottom right corner of the white canvas (marked 
by a little green dot), it will change to a diagonal double headed arrow). 
 
Picture 149 The White Space Removed from the Letter 

 
 
To save the image, Menu -> File -> Save As, and select any image type. You may get a warning if the colours 
haven’t been changed to Black and White, but that can be ignored. 

9.3 Using Inkscape to Create an Image File 
This was done using Inkscape version 0.48.4, but other versions should be okay to use. 
 
Inkscape is a free open source vector editing (it can import bitmap/raster images) application that can be used to 
create the pattern image. It is available from the Inkscape website http://inkscape.org/en/download/ or 
http://inkscape.org/en/download/windows/. 
 
Inkscape works well with text, just add some, select it, copy it to the clipboard and then paste it into the Book 
Folding Pattern Maker. It also works well with vector images. 

http://inkscape.org/en/download/
http://inkscape.org/en/download/windows/
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9.3.1 Adding Text 
Select the Text tool for the tool bar. 
 
Picture 150 Text Tool 

 
 
Select the Font, Size and any decorations (bold, italics, etc) 
 
Picture 151 Font Properties 

 
 

Click anywhere in the drawing area, a flashing ‘insert’ will appear. Type any text you want, or type single 
letters and move them into position. 
 
Picture 152 The Text 

 
 
Select the fill colour by clicking the colour palette, and the stroke to ‘none’ by shift and clicking the ‘X’. It 
doesn’t need to be black. 
 
Picture 153 The Colour Palette 

 
 
If the text were to be pasted into the Book Folding Pattern Maker, there would be no space at the top and 
bottom of the book. 
 
Picture 154 The Text in the Book Folding Pattern Maker with no Top or Bottom Space 

 
 
To add some white space, add a rectangle box and fill the colour with white, and the stroke as ‘none’ or white. 
 
Picture 155 The Rectangle Tool 

 
 
If the rectangle is moved over the text, it will obscure the text. The rectangle needs to be lowered using the 
menu command Object->Lower (or use the Page Down key). 
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Picture 156 Rectangle Obscures Text 

 
 
Picture 157 The Text is now on Top 

 
Resize the rectangle and move it into the required position. The width is about the same as the text width. 
 
Picture 158 The Rectangle Moved into Position 

 
 
Select both the text and rectangle and copy them into the clipboard (Ctrl + C), then paste into Book Folding 
Pattern Maker. 
 
Picture 159 The Text with Top and Bottom Space in Book Folding Pattern Maker 

 
 
The SVG drawing can be saved for later, but to use it in Book Folding Pattern Maker, it must be a bitmap/raster 
image. 

9.3.2 Adding Vectors 
To use a vector file, just load it into Inkscape (or create one from scratch) and make sure that there is a solid fill 
of black. 
 
Don’t forget to add space at the top and bottom of the image. 

9.4 Creating the Folded Book from the Pattern Files 
You will need: - 
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• A ruler in centimetres (cm) or millimetres (mm) 
• Optionally a setsquare 
• A bone folder to crease the pages 
• Pencil or pen 
• Eraser/rubber 
• Elastic band to keep the folded pages out of the way 
• A hardback book with the correct number of pages, and of good quality paper 
• A print out of the preview pattern image and pattern marking list 
• Some patience 

9.4.1 You Tube Videos 
These are some videos (there are may more) showing how the books are folded. The Measure, Mark, Cut and 
Fold and Measure, Mark and Fold are what this software uses. 

9.4.1.1 Mark, Cut and Fold 
Peerless Designs – Cut and Fold TV Show – How To 
http://www.youtube.com/watch?v=z38AwE9K1JY 

9.4.1.2 Mark, Cut and Fold Combination 
All in the Folds - Fold and cut and fold combination method 
http://www.youtube.com/watch?v=XSO9pJxT29c 

9.4.1.3 Measure, Mark, Cut and Fold 
Heather Duncan - Cut and fold book folding 
http://www.youtube.com/watch?v=1ofDaAc9K_o 
 
Cristina Holgersson - Book folding Cut and fold technique 
http://www.youtube.com/watch?v=0QP_Y2O8l2g 

9.4.1.4 Measure, Mark and Fold 
Debbi Moore – Bookfolding Guide 
http://www.youtube.com/watch?v=JxdG3r4zbJA 
 
Loulou Purple Crafts – How I Make my Book Folding Art 
http://www.youtube.com/watch?v=HcWakg9htQ8 
 
Susan Middleton – An Introduction to Book Folding 
http://www.youtube.com/watch?v=LR7D1hbFp3U 
 
Jacob Stocks – Book Folding Vid 
http://www.youtube.com/watch?v=vPCQUl3GMS0 
 
The Bookfolding and Craft Café - How to do bookfolding for beginners 
http://www.youtube.com/watch?v=xgRFKzkDMQw 

9.4.1.5 Mark and Fold 
Peerless Designs – Book Folding Instructions 
http://www.youtube.com/watch?v=f3juDLmoXk4 
 

http://www.youtube.com/watch?v=z38AwE9K1JY
http://www.youtube.com/watch?v=XSO9pJxT29c
http://www.youtube.com/watch?v=1ofDaAc9K_o
http://www.youtube.com/watch?v=0QP_Y2O8l2g
http://www.youtube.com/watch?v=JxdG3r4zbJA
http://www.youtube.com/watch?v=HcWakg9htQ8
http://www.youtube.com/watch?v=LR7D1hbFp3U
http://www.youtube.com/watch?v=vPCQUl3GMS0
http://www.youtube.com/watch?v=xgRFKzkDMQw
http://www.youtube.com/watch?v=f3juDLmoXk4
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11.1 Un-Installing 
The Crafty49’s Book Folding Pattern Maker application can be un-installed from the Start Menu (see Picture 
160 Un-installing from the Start Menu (Windows XP)). 
 
If there isn’t a Crafty49’s Book Folding Pattern Maker Start Menu folder, the program can be un-installed from 
the Windows ‘Add/Remove Programs’ control panel. 
 
It can also be un-installed from double clicking on the unins000.exe in the Crafty49’s Book Folding Pattern 
Maker installed folder. This is usually in the C:\Program 
Files\IdeasRUsSoftware\Crafty49sBookFoldingPatternMakerFull folder for a Full release, or 
C:\Program Files\IdeasRUsSoftware\Crafty49sBookFoldingPatternMakerDemo for the Demo release. 
 
The *.licence file will not be deleted. 
 
Picture 160 Un-installing from the Start Menu (Windows XP) 

 

 
 
A confirmation pop-up message box will be displayed, click ‘Yes’ to install, and ‘No’ to cancel uninstall. 
 
Picture 161 Confirm Uninstall 

 
 
The Crafty49’s Book Folding Pattern Maker application has been successfully removed. 
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Picture 162 Successfully Uninstalled 

 
 

11.2 Keyboard Shortcuts 
Open File  Ctrl + O 
Save Pattern Files As Ctrl + Shift + S 
Exit Program  Alt + F4 
Paste Image  Ctrl + V 
Help   F1 
Check for Updates Ctrl + U 

11.3 Previous Release Notes 
11.3.1 Changes Made in Version 1.0.75 
11.3.1.1 New Features 

• Measure, Mark, Cut and Fold Method (shortened to Cut and Fold) 
• Removes excess white from around the design pattern 
• Invert (make negative), and Mirror the design pattern 
• Add top and bottom margins to the design pattern 
• Add blank leaves before and after the design pattern 
• Add ‘spacer folds’ between the design pattern for the Cut and Fold method 
• Choose between leaf or page numbering, with an adjustable start value 

11.3.1.2 Issues Fixed 
• A black line was added to the right-hand side of the bitmap. This caused the bitmap to shrink when 

‘Remove Column Space between Shapes’ was set and the bitmap didn't contain any blank columns. 
Fixed. 

• ‘Remove Column Space between Shapes’ was removing 1 more blank column than it should. Fixed. 
• When an error occurred creating a pattern document, the progress form was blocking the error message 

pop up, making it difficult to close without moving the progress form. Fixed. 
• The size of the book in the PDF pattern documents didn’t show decimal centimetres. Fixed. 
• With no original image loaded, ticking the ‘Remove Space between Shapes’ check box caused an error. 

Disabled the group panel 'Original Image' until an image was loaded. Fixed. 
• For the Demo version, the Units group box and the Pattern Name text box was disabled when the 

Pattern Details grouped box was disabled. Fixed. 
• An error creating PDF/Pattern files wasn't disabling various controls to stop the pattern being printed or 

saved. Fixed. 
• When an image was loaded, the threshold and check boxes in the Original Image group panel were not 

reset to their starting values. Fixed. 

11.3.1.3 Updated 
Changed the text 'Beta' to 'Demo' in a number of forms/pop up boxes. 
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11.3.1.4 Improvements Made 
• The form’s maximum control has been re-enabled. 
• Any image that contains a transparent background is changed to white. Some of the newer options in the 

Original Image group box didn’t work correctly with a transparent background. 
• The option to ‘Remove Blank Columns’ from the Original Image has been changed to ‘Remove Column 

Space between Shapes’. 
• To be consistent with the Cut and Fold method, any blank leaves removed due to the ‘Min Distance 

Between Marks’ setting, are not removed for the Mark and Fold method. 
• The pattern details boxes are made bigger. 
• The way the Pattern Image is created from the Original Image. 
• The Pattern Preview Image when saved as PDF and pattern files, contained red (alternate lines) or blue 

(blank folds) indicator lines. This was okay when creating the pattern to see how the pattern would look, 
but not in finished documents or files. Removed text in the PDF file that described what the lines were. 

11.3.2 Changes Made in Version 1.0.00 
The version change jump is to coincide with the Full release version. 

11.3.2.1 New Features 
• Added a menu item for User Guide in the Help menu. 
• Added a menu item for the Installation Folder in the Help menu. 
• An ‘Product Brand’ icon to the .exe file and to the main form 

11.3.2.2 Issues Fixed 
• When a non-picture file is opened, an out of memory exception error occurs. Fixed 
• Any patterns created and not saved when a new image was opened, an image dropped onto form, an 

image pasted or the application was closed, would be lost. A pop-up message box will ask whether to 
continue with operation or not. Fixed. 

11.3.2.3 Updated 
• Changed a link on the Help -> About Form to ‘ideas-r-us-software.co.uk’, and changed the name from 

‘Ideas R Us’ to ‘Ideas R Us Software’ 

11.3.2.4 Improvements Made 
Disabled the form’s maximise control button, since no form controls are re-sizable. 

11.3.3 Changes Made in Version 0.5.02 
11.3.3.1 New Features 

• An option to remove the blank/un-folded page leaves from the pattern, by removing the blank/white 
space from the bitmap. It will also remove any blank leaves when the pattern is created. 

• A print preview button to the toolbar. 

11.3.3.2 Issues Fixed 
There was an error when saving the pattern files on Windows 7/8.x/10. Fixed. 
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11.3.4 Changes Made in Version 0.5.01 
11.3.4.1 New Features 

• The application can now exit when the form-closed button is clicked or when the menu item File->Exit 
is selected. It will also check and warn of unsaved pattern files. 

• A progress pop-up box when printing/previewing and saving the pattern files. 
• Saving the pattern folding/marking points as CSV file when saving the pattern set files, instead of the 

pattern table as a text file. 

11.3.4.2 Improvements 
The paste button and menu item are only enabled when there are supported bitmap/raster image in the 
clipboard. 

11.3.5 Changes Made in Version 0.5.00 
11.3.5.1 New Features 

• The Original Image bitmap (what appears in the Original Image group panel) is now saved with the 
pattern set. 

• Replaced the old formatted pattern document with a visually improved version that has the pattern 
details on the first page. 

• The formatted pattern document is also saved as a PDF file with the pattern set. 
• Any changes that have been made to the Original Image threshold, the Pattern Details, or Book Details, 

will disable the Print/Preview and Save All Pattern files until the pattern have been created. 

11.3.6 Changes Made in Version 0.1.05 
11.3.6.1 New Features 

• Selecting of the units cm or mm on the form. 
• The pattern file of folding/marking points to use cm or mm. 
• Blue lines to the pattern preview image to indicate blank or non-folded pages. 

11.3.6.2 Improvements 
• Changed the form layout. Added group panels and moved controls. 
• Renamed ‘Total Pages’ to ‘Actual Pages’ on the form. 
• Removed the ‘Folded Pages’ count on the form. All the pages can be folded, and not just the marked 

ones. 
• The Pattern Image was stretched too much when the book leaves increased. Removed all the zoom and 

resize controls, and just scale the pattern image to fit when necessary. 

11.3.7 Changes Made in Beta/Pre-Release Version 0.1.04 
11.3.7.1 New Features 

• A menu item to check for updates for new versions/releases. 
• A licence Nag screen for Beta releases with an expiry date. 
• An about box with licence info. 
• The pattern output is 4 columns. 
• Paste bitmaps/raster images from clipboard, using the keyboard, menu or toolbar. 
• Drag and drop of a supported bitmap/raster file onto the form. 
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• Printing of the original bitmap, pattern bitmap and patterns. 

11.3.7.2 Issues Fixed 
• The book leaves entered did not create the correct number of leaves due to ‘alternate’ folds. The number 

of book leaves entered is now exact or near enough. Fixed. 
• The total page count was 1 greater than it should be. Fixed. 
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