
For additional handouts, visit http://www.calstatela.edu/handouts. 
For video tutorials, visit http://www.youtube.com/mycsula. 

CALIFORNIA STATE UNIVERSITY, LOS ANGELES 
INFORMATION TECHNOLOGY SERVICES 

Microsoft Access 2010 
Part 1: Introduction to Access 

Fall 2014, Version 1.2 

Table of Contents 
Introduction ....................................................................................................................................3 
Starting Access ...............................................................................................................................3 
Overview of the User Interface .....................................................................................................3 

Quick Access Toolbar .................................................................................................................4 
Ribbon .........................................................................................................................................5 
Navigation Pane ..........................................................................................................................6 
Backstage View ...........................................................................................................................7 

Overview of Databases ..................................................................................................................7 
Database Objects .........................................................................................................................7 
Designing Databases ...................................................................................................................8 

Opening Databases.........................................................................................................................8 
Opening Database Objects ..........................................................................................................9 
Working in Datasheet View ......................................................................................................10 
Switching Between Views ........................................................................................................10 
Closing Database Objects .........................................................................................................11 
Renaming Database Objects .....................................................................................................11 
Deleting Database Objects ........................................................................................................12 

Creating Databases ......................................................................................................................12 
Working with Tables ...................................................................................................................14 

Creating Tables .........................................................................................................................14 
Creating Tables in Datasheet View ......................................................................................15 

Adding Fields by Entering Data ......................................................................................15 
Renaming Fields ..............................................................................................................16 

Creating Tables in Design View ..........................................................................................17 
Defining Fields ................................................................................................................17 
Setting a Primary Key .....................................................................................................19 

Saving Tables ............................................................................................................................20 
Editing Tables ...........................................................................................................................20 

Adding Fields .......................................................................................................................20 
Deleting Fields .....................................................................................................................21 
Reordering Fields .................................................................................................................21 

http://www.calstatela.edu/handouts
http://www.youtube.com/mycsula


Microsoft Access 2010 Part 1: Introduction to Access 2 

Adding Records ....................................................................................................................22 
Deleting Records ..................................................................................................................23 

Closing Databases ........................................................................................................................23 
Getting Help .................................................................................................................................23 
Exiting Access ...............................................................................................................................24 

 
  



Microsoft Access 2010 Part 1: Introduction to Access 3 

Introduction 
Microsoft Access 2010 is a powerful relational database program that can be used to track, share, 
and report information. It provides access to a large library of professionally designed templates; 
wizards that automatically create tables, queries, forms, and reports; and extensive local and 
online help resources. This handout provides an overview of the Access 2010 user interface and 
covers how to perform basic tasks such as opening and closing databases, managing database 
objects, creating new databases, creating and modifying tables, and getting help. 

Starting Access 
You can start Access 2010 from the Start menu (in Windows 7) or by opening an existing Access 
file. When you start the program without opening a specific file, the Backstage view opens, 
prompting you to create a new database or open an existing database. 
 
To start Access 2010 from the Start menu: 

1. Click the Start button, click All Programs, click Microsoft Office, and then click 
Microsoft Access 2010. The New page of the Backstage view opens, displaying 
thumbnails of the available templates and template categories (see Figure 1). 

2. Under Available Templates, click Blank database. 
3. Click the Create button. A blank database opens in the program window and a blank 

table named Table1 opens in Datasheet view. 

 
Figure 1 – New Page of the Backstage View 

Overview of the User Interface 
All the Microsoft Office 2010 programs share a common user interface so you can apply basic 
techniques that you learn in one program to other programs. The Access 2010 program window 
is easy to navigate and simple to use (see Figure 2 and Table 1). 
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Figure 2 – Access 2010 Program Window 

Table 1 – Access 2010 Program Window Elements 

Name Description 
Title bar Appears at the top of the program window and displays the name of 

the database and the program. The buttons on the right side of the Title 
bar are used to minimize, maximize, restore, and close the program 
window. 

Quick Access toolbar Appears on the left side of the Title bar and contains frequently used 
commands that are independent of the tab displayed on the Ribbon. 

Ribbon Extends across the top of the program window, directly below the 
Title bar, and consists of a set of tabs, each of which contains groups 
of related commands. 

Navigation pane Appears on the left side of the program window and displays a list of 
all the objects in a database. 

Object window Appears below the Ribbon and displays open database objects. 
Status bar Appears at the bottom of the program window and displays 

information about the database and provides access to certain program 
functions. 

Quick Access Toolbar  
The Quick Access toolbar provides one-click access to commonly used commands and options. 
By default, it is located on the left side of the Title bar and displays the Save, Undo, and Redo 
buttons (see Figure 3). You can change the location of the Quick Access toolbar as well as 
customize it to include commands that you use frequently. 

 
Figure 3 – Quick Access Toolbar 
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To add a command to the Quick Access toolbar: 

1. On the Ribbon, right-click the command that 
you want to add, and then click Add to Quick 
Access Toolbar on the shortcut menu. 

 
To remove a command from the Quick Access toolbar: 

1. On the Quick Access toolbar, right-click the 
command that you want to remove, and then 
click Remove from Quick Access Toolbar on 
the shortcut menu. 

 
NOTE: Clicking the arrow on the right side of the Quick 
Access toolbar displays a menu which includes additional 
commands and options that can be used to customize the 
toolbar. A check mark next to an item indicates that the item 
is selected (see Figure 4). 

 
Figure 4 – Customize Quick Access 

Toolbar Menu 

Ribbon 
The Ribbon is designed to help you quickly find the commands that you need to complete a task. 
It consists of a set of task-specific tabs (see Figure 5 and Table 2). The main tabs are visible at all 
times. Other tabs, known as contextual tabs, appear only when you are working with specific 
database objects and in various views. These tabs are indicated by colored headers and contain 
commands that are specific to working with the selected object. Clicking a tab displays a set of 
related commands that are organized into logical groups. Commands generally take the form of 
buttons and lists; some appear in galleries. Some commands include an integrated or separate 
arrow; clicking the arrow displays options available for the command. The appearance of the 
buttons and groups on the Ribbon changes depending on the width of the program window. If a 
command on the Ribbon appears dimmed, it is unavailable. Pointing to a command on the 
Ribbon displays its name, description, and keyboard shortcut (if it has one) in a ScreenTip. 
 
A dialog box launcher  appears in the lower-right corner of most groups on the Ribbon (see 
Figure 5). Clicking it opens a related dialog box or task pane which offers additional options or 
more precise control than the commands available on the Ribbon. 
 
You can minimize the Ribbon to make more space available on the screen by clicking the 
Minimize the Ribbon button  on the right side of the Ribbon (see Figure 5). You can expand 
the Ribbon by clicking the Expand the Ribbon button . When the Ribbon is minimized, only 
the tab names are visible. 

 
Figure 5 – Ribbon 
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Table 2 – Ribbon Tabs 

Name Description 
File Displays the Backstage view which contains commands related to managing 

files and customizing the program. The File tab replaces the Microsoft 
Office button and File menu used in earlier releases of Microsoft Office. 

Home Contains the most frequently used commands. The Home tab is active by 
default. 

Create Contains commands used to create new database objects (tables, queries, 
forms, reports, macros, and modules). Each group on this tab arranges its 
specific functions by database object type. 

External Data Contains commands used to import from or link to data in external sources 
or export data to external sources. 

Database Tools Provides access to miscellaneous tools and wizards. 

Navigation Pane 
The Navigation pane is a central location from which you can easily view and access all your 
database objects (see Figure 6). By default, it appears along the left side of the program window 
and displays all the objects in the database, grouped by object type and sorted by object name. 
When the list of objects is longer than can be displayed within the height of the Navigation pane, 
Access provides a scroll bar. You can collapse and expand the groups in the list by clicking the 
section bars. You can also change the display in the Navigation pane by clicking the pane’s Title 
bar and selecting a different category or filter from the menu (Figure 7). 
 
You can minimize the Navigation pane to maximize the amount of screen area available to work 
with open database objects. Clicking the Shutter Bar Close button  in the upper-right corner of 
the pane makes it appears as a thin bar on the left side of the program window. Clicking the 
Shutter Bar Open button  at the top of the minimized pane expands it. You can also drag the 
right edge of the Navigation pane to the left or right to make it wider or narrower. 
 

 
Figure 6 – Navigation Pane 

 
Figure 7 – Navigation Pane Menu 

 



Microsoft Access 2010 Part 1: Introduction to Access 7 

Backstage View 
The File tab (the first tab on the Ribbon) is used to display the Backstage view which contains all 
the commands related to managing files and customizing the program. It provides an easy way to 
create, save, print, open, and close files; find recently used files; view and update file properties; 
set permissions; set program options; get help; and exit the program. 
 
You can display the Backstage view at any time by clicking the File tab on the Ribbon (see 
Figure 8). You can exit the Backstage view by clicking any tab on the Ribbon or by pressing the 
Esc key. 

 
Figure 8 – Info Page of the Backstage View 

Overview of Databases 
A database is a collection of information that is related to a particular subject or purpose. 
Databases help you organize this related information in a logical fashion for easy access and 
retrieval. Electronic databases simplify tasks such as searching for specific data, organizing and 
sorting data, and making corrections or changes to data. 
 
Access 2010 is a powerful relational database program. An Access database can store data in 
multiple related tables, thereby creating what are referred to as relational databases. If the data in 
a relational database is organized correctly, you can treat these multiple tables as a single storage 
area and pull information electronically from different tables in whatever order meets your 
needs. 

Database Objects 
An Access database can contain six types of objects: tables, queries, forms, reports, macros, and 
modules (see Table 3 for a description of each object type). Database objects are created to input, 
edit, retrieve, display, or print data. The names of all the database objects are displayed in the 
Navigation pane. 
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Table 3 – Database Objects 

Object Type Object Purpose 
Table Used to store data about a particular subject. 
Query Used to retrieve data that matches one or more conditions, to perform 

calculations, to combine data from different tables, or to add, change, or 
delete data. 

Form Used to view, enter, and edit data. 
Report Used to format, summarize, and present data. 
Macro Enables you to automate tasks and add functionality to your database without 

writing code. You build a macro by selecting each action from a list. 
Module Enables you to add automation and other functionality to your database by 

writing code in the Visual Basic for Applications (VBA) programming 
language. 

Designing Databases 
The most basic object in a database is a table in which you store your data. The following 
guidelines will help you create efficient tables. 

 One table per subject: The first rule in creating database tables is to ensure that every 
table stores data about one subject. 

 Give every table a primary key: Another important consideration in creating a table is 
to assign a primary key. This field contains a value that sets a record apart from all other 
records in the table. 

 Include foreign keys: A final thing you can do to make your tables more efficient is to 
include foreign keys. When a primary key from one table is stored in another table, it is 
called a foreign key. You can use foreign keys to create relationships between tables. 

Opening Databases 
You can view or edit an existing database by opening it in Access. Once the database file is 
loaded into memory, you can open all the tables or other objects within that database. 
 
NOTE: Each time you start Access, you open an instance of it. In a single instance of Access, you can 
have only one database open at a time. So to open two Access databases at the same time, start Access 
and open the first database, and then start Access again and open the second database. Each instance of 
Access runs in a separate window. 
 
To open an existing database: 

1. Click the File tab, and then click Open. 
2. In the Open dialog box, locate and select the file that you want to open, and then click 

the Open button. 
NOTE: When you open a database that contains potentially unsafe active content (such as action 
queries, macros, expressions, ActiveX controls, or VBA code), a Security Warning message is 
displayed on the Message bar, just below the Ribbon. If you know the content is from a reliable 
source, click the Enable Content button on the Message bar (see Figure 9). 

 
Figure 9 – Message Bar 
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NOTE: When you open a database, the file name and location of the database are added to the 
Recent Databases list which is displayed on the Recent page of the Backstage view (see Figure 
10). This allows you to quickly access recently used files. 

 
Figure 10 – Recent Page of the Backstage View 

Opening Database Objects 
You can open any object in a database by double-clicking it in the Navigation pane. Each open 
object appears on a tab in the Object window. The view in which the data appears depends on the 
type of object you open. Tables and queries appear in Datasheet view; forms appear in Form 
view; reports appear in Report view; and macros and modules run programs attached to the 
object. 
 
To open a table: 

1. In the Navigation pane, double-click the table that you want to open. The table opens in 
the Object window in Datasheet view (see Figure 11). 

 
Figure 11 – Table in Datasheet View in the Object Window 

NOTE: If you have multiple objects open in the Object window, you can easily switch between 
them by clicking the object tabs. The active object tab is orange and the tab title is displayed in 
bold text. 
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Using Datasheet View 
In Datasheet view, displaying different records or fields is simple. You can use the horizontal 
scroll bar to scroll through a table’s fields, or you can use the vertical scroll bar to scroll through 
a table’s records (see Figure 12). 

 
Figure 12 –Scroll Bars and Record Navigation Bar in Datasheet View 

The Record Navigation bar located at the bottom of the Object window indicates how many 
records the table contains and which one is active, and enables you to navigate through the 
datasheet records (see Figure 12). 

 Click the First record button  to go to the first record in the datasheet. 
 Click the Previous record button  to go to the previous record in the datasheet. 
 If you know the record number (the row number of a specific record), click in the 

Current Record box , type the record number, and then press the Enter key. 
 Click the Next record button  to go to the next record in the datasheet. 
 Click the Last record button  to go to the last record in the datasheet. 
 Click the New (blank) record button  to go to the new record row in the datasheet. 

Switching Between Views 
Every Access object has two or more views. 
For tables, the two most common views are 
Datasheet view (which allows you to view 
and modify the table’s data), and Design view 
(which allows you to view and modify the 
table’s structure). 
 
To switch between views: 

1. On the Home tab, in the Views group, 
click the View arrow and select the 
desired view from the menu (see 
Figure 13). Or, click the desired view 
button on the View Shortcuts toolbar 
located on the right side of the Status 
bar (see Figure 14). 
NOTE: The available views vary 
depending on the open object. 

 
Figure 13 – View Menu 

 
Figure 14 – View Shortcuts Toolbar 
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Closing Database Objects 
When you finish working on a database object, you can close it, but keep the database open to 
work on other objects. 
 
To close a table: 

1. In the Object window, select the table that you want to close. 
2. Click the Close button in the upper-right corner of the Object window (see Figure 15). 

 
Figure 15 – Close Button in the Object Window 

NOTE: You can close all open objects at once by right-clicking any tab, and then clicking Close 
All on the shortcut menu. 

Renaming Database Objects 
You can rename the objects in a database. Before renaming an object, make sure that it is closed. 
 
To rename a table: 

1. In the Navigation pane, right-click the table that you want to rename, and then click 
Rename on the shortcut menu. The table name is placed in edit mode (see Figure 16). 

2. Type a new name, and then press the Enter key. The tables in the Tables list are re-
sorted in alphabetical order. 
NOTE: If you enter the name of a table that already exists in the database, a dialog box opens 
asking whether you want to replace the existing table. If you click the Yes button, Access deletes 
the old table before performing the renaming operation. 

 
Figure 16 – Table Name in Edit Mode 
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Deleting Database Objects 
You can delete an object from a database if it is no longer needed. Before deleting an object, 
make sure that it is closed. 
 
To delete a table: 

1. In the Navigation pane, right-click the table that you want to delete, and then click 
Delete on the shortcut menu. 

2. A dialog box opens asking you to confirm. Click the Yes button (see Figure 17). 

 
Figure 17 – Microsoft Access Dialog Box 

Creating and Saving Databases 
When you create a new database, you create a file that acts as a container for all of the objects in 
your database. Access 2010 comes with a variety of templates that you can use to speed up the 
database creation process. A template is a ready-to-use database that contains all the tables, 
queries, forms, and reports needed to perform a specific task. If none of the templates meets your 
needs, you can build a database from scratch by creating a blank database, and then adding your 
own tables and other database objects. 
 
NOTE: By default, Access 2010 creates databases in the .accdb file format which was introduced in 
Access 2007. A database in this file format cannot be opened by using versions of Access earlier than 
Access 2007. If you need to share your database with people who use Access 2003 or earlier, you must 
use the .mdb file format. 
 
To create a new database: 

1. Click the File tab, and then click New. The New page of the Backstage view opens, 
displaying thumbnails of the available templates and template categories (see Figure 18). 

2. Under Available Templates, click Blank database. 
3. In the File Name box, type a name for the database. 

NOTE: File names cannot contain the following characters: forward slash (/), backslash (\), 
greater than sign (>), less than sign (<), asterisk (*), question mark (?), quotation mark ("), pipe 
symbol (|), and colon (:). 

4. Click the Browse button  next to the File Name box. In the File New Database dialog 
box, select the folder where you want to save the database, and then click the OK button. 
The path to the specified folder is displayed below the File Name box. 
NOTE: You cannot create a blank database without saving it. If you do not provide a file name 
and location, Access saves the file with the name Database followed by a sequential number in 
the Documents folder. 
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Figure 18 – New Page of the Backstage View 

5. Click the Create button. A blank database opens in the program window and a blank 
table named Table1 opens in Datasheet view (see Figure 19). 
NOTE: If you close Table1 at this point, Access will not prompt you to save the table because it 
contains no data and it has no structure. The simplest way to make the table part of the database is 
to create at least one record by entering data, which simultaneously defines the table’s structure. 

6. Click the Close button in the upper-right corner of the Object window. 
NOTE: The following sections show you various methods of creating a new table. 

 
Figure 19 – New Table in a New Database 
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Working with Tables 
A table is a database object that you define and use to store data. Each table contains information 
about a particular subject (such as customers). A table consists of records and fields. Each record 
contains data about one instance of the table subject (such as a particular customer). Each record 
consists of one or more fields. Each field contains data about one aspect of the table subject 
(such as a customer’s first name or email address). Because other database objects depend so 
heavily on tables, you should always start your design of a database by creating all of its tables, 
and then creating any other objects. 
 
In Datasheet view, a table is similar in appearance to an Excel worksheet in that data is stored in 
rows (records) and columns (fields). The first row contains column headers (field names). In this 
format, the table is often simply referred to as a datasheet (see Figure 20). 

 
Figure 20 – Table 

When the active object is a table, the Table Tools contextual tabs (Fields and Table) become 
available on the Ribbon so that you can work with the table (see Figure 21 and Figure 22). 

 
Figure 21 – Table Tools Fields Tab 

 
Figure 22 – Table Tools Table Tab 

Creating Tables 
When you create a new table, you have complete control over the number of fields, the names of 
the fields, and what sort of data they can store. You can create a new table in either Datasheet 
view or Design view by using the commands in the Tables group on the Create tab of the Ribbon 
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(see Figure 23). Regardless of which view you start in, you can always switch to the other view 
by using the View button on the Ribbon or by clicking the various view buttons on the View 
Shortcuts toolbar. 

 
Figure 23 – Tables Group on the Create Tab 

Creating Tables in Datasheet View 
In Datasheet view, you can enter data into a new table without first defining the table’s structure. 
 
To create a table in Datasheet view: 

1. On the Create tab, in the Tables group, click the Table button . A new, blank table 
opens in the Object window in Datasheet view (see Figure 24). 

 
Figure 24 – New Table in Datasheet View 

Adding Fields by Entering Data 
Entering data in Datasheet view is designed to be very similar to entering data in an Excel 
worksheet. The main restriction is that data must be entered in contiguous rows and columns, 
starting in the upper-left corner of the datasheet. The table structure is created while you enter 
data. Any time you add a new column to the datasheet, a new field is defined in the table. 
 
In each new table created in Datasheet view, Access automatically creates the first field, called 
ID, in the left column of the datasheet (see Figure 25). By default, this field is designated as the 
table’s primary key and is designed to contain an entry that will uniquely identify the record; the 
data type of this field is set to AutoNumber which means that Access will automatically enter a 
sequential number in this field for each new record you add. You can add a new field to the table 
by entering data in the Click to Add column (the last column) of the datasheet; Access will 
automatically assign a data type based on the data that you enter. 

 
Figure 25 – First Record in a New Table Before Data is Entered 
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To add a field by entering data: 
1. Click in the first cell in the Click to Add column, enter the first item of data for the new 

record, and then press the Tab or Enter key to move to the first cell in the column to the 
right. Access assigns the value 1 to the ID field, assigns the name Field1 to the second 
field, and moves the Click to Add label to the third column. The icon on the row selector 
changes to a pencil to indicate that the record has been changed, but has not yet been 
saved, and the asterisk (*) icon moves to the row selector of the next row (see Figure 26). 

 
Figure 26 – First Record in a New Table After Entering Data 

NOTE: When creating a new table in Datasheet view, you need to save the first record after 
entering the first item of data. If you do not, Access increments the ID value for each field you 
add to that record. 

2. Click the pencil icon in the row selector. This saves the first record with the value 1 
assigned to the ID field; subsequent records will be numbered sequentially. 

3. Continue entering items of data in consecutive cells, and pressing the Tab or Enter key. 
4. When you finish entering all the data for the first record, click anywhere in the row below 

to save the record. 
 
After you complete the first record of a new table, you should change the default field names to 
something more meaningful. For instructions, see the Renaming Field section of this handout. 
 
After you enter several rows of data, it is a good idea to save the table. For instructions, see the 
Saving Table section of this handout. 

Renaming Fields 
When you add a field by entering data in Datasheet view, Access automatically assigns a generic 
name to the field. Access assigns the name Field1 to the first new field, Field2 to the second new 
field, and so on (see Figure 27). By default, a field’s name is used as its label wherever the field 
is displayed (such as a column header on a datasheet). Renaming fields so that they have more 
descriptive names helps make them easier to use when you view or edit records. 

 
Figure 27 – Table with Generic Field Names 

To rename a field in Datasheet view: 
1. In the Object window, double-click the field name, type the new name, and then press 

the Enter key. 
NOTE: Field names can be up to 64 characters long. They can include any combination of letters, 
numbers, spaces, and special characters, except a period (.), an exclamation point (!), a grave 
accent (`), and brackets ([ ]). 
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Creating Tables in Design View 
When you create a table in Design view, you have more control over the database design. You 
first create the new table’s structure in Design view, and then you switch to Datasheet view to 
enter data. 
 
In Design view, the Object window consists of two panes (see Figure 28). The Field Entry pane, 
located at the top of the window, is used to enter each field’s name, data type, and description. 
The Field Properties pane, located at the bottom of the window, is used to specify the field’s 
properties. The properties available in the Field Properties pane depend on the data type assigned 
to the selected field. On the right side of the Field Properties pane is a box in which Access 
displays information about fields or properties. 
 
To create a table in Design view: 

1. On the Create tab, in the Tables group, click the Table Design button . A new, blank 
table opens in the Object window in Design view (see Figure 28). 

 
Figure 28 – New Table in Design View 

Defining Fields 
Every table is made up of fields. Each field has a set of properties that control the way it stores, 
handles, and displays data (e.g., field size, format, input mask, default value). A field’s data type 
is the most important property because it determines what kind of data the field can store (see 
Table 4 for a description of each data type). 
 
In Design view, you create a new field by entering the field’s name, specifying the field’s data 
type, and (optionally) specifying its other properties. The field’s name uniquely identifies the 
field within a table. The field’s description indicates the field’s purpose and is optional. The 
field’s data type determines which other properties you can set. Access automatically assigns 
default field properties which you can modify as needed. 
 
NOTE: The order in which the field names appear in Design view determines the order in which the 
columns appear in Database view. 
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Table 4 – Access Data Types 

Data Type Usage 
Text Text is the default data type. Text fields accept either text or numeric data, 

including delimited lists of items (up to 255 characters). 
Memo You can enter large amounts of text and numeric data in this type of field (up to 

65,538 characters). Also, if the field is set to support rich text formatting, you 
can apply the types of formatting that you normally find in word processing 
programs such as Word. 

Number You can enter only numbers in this type of field, and you can perform 
calculations on the values in a Number field. 

Date/Time You can enter only dates and times in this type of field. 
Currency You can enter only currency values in this type of field. You do not have to 

manually enter a currency symbol. By default, Access applies the currency 
symbol ($, ¥, £, and so on) specified in your Windows regional settings. 

AutoNumber You cannot enter or change the data in this type of field. Access increments the 
values in an AutoNumber field whenever you add a new record to a table. 

Yes/No When a field is set to this data type, Access displays either a check box or a 
drop-down list, depending on how you format the field. If you format the field 
to show a list, you can select either Yes or No, True or False, or On or Off from 
the list, again depending on the format applied to the field. You cannot enter 
values in the list or change the values in the list directly from a form or table. 

OLE Object You use this type of field when you want to display data from a file created 
with another program. 

Hyperlink You can enter any data in this type of field and Access adds http:// to your text. 
If you enter a valid web address, your link will work. Otherwise, your link will 
result in an error message. 

Attachment You can attach data from other programs to this type of field, but you cannot 
type or otherwise enter text or numeric data. 

Calculated This data type lets you create a field that is based on a calculation of other 
fields in the same table. 

Lookup 
Wizard 

The Lookup Wizard is not a data type. Instead, you use the wizard to create a 
lookup field. A lookup field displays either a list of values that is retrieved from 
a table or query, or a set of values that you specify when you create the field. A 
lookup field allows you to choose values from a list during data entry, thereby 
reducing repetitive typing and eliminating typing errors. 

 
To define fields: 

1. In the Field Name column, type a name for the first field. 
NOTE: Field names can be up to 64 characters long. They can include any combination of letters, 
numbers, spaces, and special characters, except a period (.), an exclamation point (!), a grave 
accent (`), and brackets ([ ]). 

2. In the Data Type column, click the down arrow and select a data type from the list (see 
Figure 29 and Table 4). The Field Properties pane displays the available properties for 
the selected data type (see Figure 30). 
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Figure 29 – Data Type List 

 
Figure 30 – Field Properties Pane 

3. In the Description column, type a description for the field. 
4. Repeat steps 1 through 3 to add additional fields to the table. 

 
After you add all of your fields, you must save the table before you can add any data. For 
instructions, see the Saving Table section of this handout. 

Setting a Primary Key 
A primary key consists of one or more fields that uniquely identify each record in the table. 
There are several advantages to setting a primary key. First, the primary key is automatically 
indexed, which makes information retrieval faster. Second, when you open a table, the records 
are automatically sorted in order by the primary key. Finally, a primary key prevents the entry of 
duplicate data. 
 
When you create a new table in Datasheet view, Access automatically creates a primary key for 
you and assigns it a field name of ID and the AutoNumber data type. In Design view, you can 
change or remove the primary key, or set the primary key for a table that does not already have 
one. 
 
To set a primary key: 

1. Click the row selector of the field you want to designate as the primary key. 
NOTE: To select more than one field, hold down the Ctrl key and click the row selector of each 
field. 

2. On the Design tab, in the Tools group, click the Primary Key button (see Figure 31). A 
key icon appears to the left of the field that you specify as the primary key (see Figure 
32). 

 
Figure 31 – Tools Group on the Design Tab 



Microsoft Access 2010 Part 1: Introduction to Access 20 

 
Figure 32 – Table After Setting a Primary Key 

Saving Tables 
After you create or modify a table, you should save it. When you save a table for the first time, 
you should give it a name that describes the data that it contains. 
 
NOTE: When you save a table, you are not creating a file. You are adding an object to the existing 
database. 
 
To save a table for the first time: 

1. On the Quick Access toolbar, click the Save button . The Save As dialog box opens 
(see Figure 33). 

2. In the Table Name box, type a name for the table. 
NOTE: Table names can be up to 64 characters long. They can include any combination of 
letters, numbers, spaces, and special characters, except a period (.), an exclamation point (!), a 
grave accent (`), and brackets ([ ]). 

3. Click the OK button. The table appears in the Tables list in the Navigation pane. 

 
Figure 33 – Save As Dialog Box 

Editing Tables 
After creating a table, you can modify the table’s structure by adding, deleting, or reordering 
fields. You can also modify the table’s data by adding new records, editing existing records, or 
deleting obsolete records. 

Adding Fields 
To store a new piece of data about something for which you already have a table, you can add a 
field to the table. 
 
To add a field: 

1. In the Navigation pane, right-click the table that you want to edit, and then click Design 
View on the shortcut menu. The table opens in Design view. 
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2. Click the row selector of the field above which you want to insert the new field. 
3. On the Design tab, in the Tools group, click the Insert Rows button . Access inserts a 

blank row that you can use to define the new field (see Figure 34). 
4. In the Field Name column, type a name for the new field. 
5. In the Data Type column, click the down arrow and select a data type for the new field. 

 
Figure 34 – Table After Inserting a Row 

Deleting Fields 
You can remove unwanted fields from a table. Deleting a field gets rid of all the data in that 
field. 
 
To delete a field: 

1. In the Navigation pane, right-click the table that you want to edit, and then click Design 
View on the shortcut menu. The table opens in Design view. 

2. Click the row selector of the field that you want to delete. 
3. On the Design tab, in the Tools group, click the Delete Rows button . 
4. If the field contains data, a dialog box opens asking you to confirm. Click the Yes button 

(see Figure 35). 

 
Figure 35 – Microsoft Access Dialog Box 

Reordering Fields 
While the order of the fields does not affect how the table functions within the database, it is a 
good practice to group fields together in some reasonable order so that they are easy to find, and 
to place the primary key field at the top of the list. 
 
To move a field: 

1. In the Navigation pane, right-click the table that you want to edit, and then click Design 
View on the shortcut menu. The table opens in Design view. 

2. Click the row selector of the field that you want to move, and then drag the row selector 
to the desired location. A line appears to show where the field will be placed when you 
release the mouse button (see Figure 36). 
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Figure 36 – Table While Moving a Field 

Adding Records 
Every table has a blank row that follows the last record in the table. This blank row, the new 
record row, displays an asterisk (*) on the row selector at the left end of the row (see Figure 37). 
As soon as you begin entering data into the new record row, the asterisk on the row selector 
changes to a pencil to indicate that the record is being entered or edited, and Access creates 
another new record row below it. If there is no data in the table, only the new record row 
appears. 

 
Figure 37 – Table in Datasheet View 

To add a record: 
1. In the Navigation pane, double-click the table that you want to edit. The table opens in 

Datasheet view. 
2. On the Home tab, in the Records group, click the New button . The insertion point is 

placed in the first column in the new record row. 
3. Enter the desired data, and then press the Tab or Enter key to move the insertion point to 

the next column in the same row. 
NOTE: If the data you enter in a column violates a field validation rule, Access notifies you as 
soon as you attempt to leave the column. You must provide a correct value before you can move 
to another column. Press the Esc key or click the Undo button  on the Quick Access toolbar to 
undo the change to the current value. 

4. Enter the desired data in the remaining columns, pressing the Tab or Enter key after 
each entry. 
NOTE: If you make a mistake, you can click the data you want to change and type over it or 
delete it. 
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5. To save the new record, press Shift+Enter at any place in the record, or press the Tab or 
Enter key in the last column in the record. Or, on the Home tab, in the Records group, 
click the Save button . 
NOTE: Access automatically saves a new record or changes made to an existing record as soon as 
you move to another row. Also, Access saves records automatically when you close a table. 

Deleting Records 
When you no longer need a record, you can delete it from the table. Deleting records saves disk 
space and keeps your tables smaller and more manageable. 
 
NOTE: Deleted records cannot be recovered. 
 
To delete a record: 

1. In the Navigation pane, double-click the table that you want to edit. The table opens in 
Datasheet view. 

2. Click the row selector of the record that you want to delete. 
3. On the Home tab, in the Records group, click the Delete button . 
4. The selected record is removed from the table, and a dialog box opens asking you to 

confirm. Click the Yes button (see Figure 38). 

 
Figure 38 – Microsoft Access Dialog Box 

Closing Databases 
When you finish working on a database, you should close the file. If the database contains any 
unsaved objects, you will be prompted to save the objects before closing the file. 
 
To close a database: 

1. Click the File tab, and then click Close Database. 

Getting Help 
You can use the Access Help system to get assistance on any Access topic or task. This system is 
a combination of tools and files that were stored on your computer when Access 2010 was 
installed. If your computer is connected to the Internet, you can also access resources from 
Office.com. 
 
To get help: 

1. Click the Microsoft Access Help button  on the right side of the Ribbon. Or, press 
the F1 key. The Access Help window opens, displaying a list of general help topics (see 
Figure 39). 
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NOTE: You can also click the Help button  in the upper-right corner of an open dialog box 
to display topics related to the functions of that dialog box in the Access Help window. 

2. Click any topic to display the corresponding information. 
3. To find help on a specific topic, type a word or phrase related to the topic in the Search 

box, and then press the Enter key. The search results display in the window. 
4. To switch between online and offline help, click the button in the lower-right corner of 

the window to display the Connection Status menu, and then click Show content from 
Office.com or Show content only from this computer (see Figure 40). 

5. To close the Access Help window, click the Close button  in the upper-right corner 
of the window. 

 

 
Figure 39 – Access Help Window 

 
Figure 40 – Connection Status Menu 

Exiting Access 
When you finish using Access 2010, you should exit the program to free up system resources. 
 
To exit Access 2010: 

1. Click the File tab, and then click Exit. Or, click the Close button  in the upper-right 
corner of the program window. 
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